IVR Custom recording not playing

Hi all,
I am new to free PBX ( I have installed free PBX and got it working. But the only challenge i am facing is the Custom recorded IVRS recordings are not playing (I can play the same files from system recordings tab). I have seen some posts regarding changing permissions in" /var/lib/asterisk/sounds/custom " . i gave full permission to every one "
-rwxrwxrwx 1 asterisk asterisk 131498 Mar 6 17:17 cutglassivr.wav " didn’t really help.

is there any thing else i cen try… would appreciate any help


How did you make the recordings in the first place?

you mean that the probleme could provides from the redording?

If the recording format is not correct then the recording will not play in your IVR. See the system recording screen. This tells you the format expected.

Im not sure where the problem is, but i am able to play the recording after uploading to system recordings section, when i use it in the IVR and configure an extension to use the IVR. I am not able to listen the recording.


I downloaded sample recordings and converted to the desired WAV format by "PCM encoded 16 Bit 8000 Hzd format.

this might be possible, I only tried WAV format, I was wondering if there are any sample recordings in GSM format, can some one point me to sample files that worked for you ?


It’s not about wav or gsm. Look at the system recording screen and it will tell you what format. There are nots of different formats within wav files.

Had the same problem, several times.
Uploaded a proper wav file I could play through FreePBX but not through Announcements or IVR.
Solution for me: just make a standard mp3 and let FreePBX convert it to what it needs.