I've installed the latest beta (SNG7-FPBX-64bit-1612-1 Beta3) Raid 1 issue

Have been using Freepbx since the old Asterisk at Home days, great product thanks…

I’ve installed the latest beta (SNG7-FPBX-64bit-1612-1 Beta3), on an Intel Nuc i3. This unit has a slot for both an m.2 drive, and standard 2.5” sata drive. Unfortunately the drives are slightly different in size (a few gig), this caused the automated installer, using the default installer to install on 1 drive instead of creating a raid 1 array, which is what I require.

If I select “Advanced Installation With Normal Video” it performs an automated installation again not allowing me to chose any install options other than root password.

If I chose “Custom Sangoma OS7 Install” I can create the array perform the install however at the end I get a stock Centos 7 base system, after I run Yum Update and Yum install Freepbx, this then installs most components however the Freepbx framework is not installed properly and is not functional.

Obviously I am doing something incorrectly any help would be appreciated.

Thanks in advance…

It is not surprising that the automated installed is not doing what you want with the different sized disks. Have you tried setting up the raid 1 manually before running the installer? Alternatively, you could let it install to one disk and convert to a raid one later. The second options is likely to be much more complicated.

As I recall (from several years ago), the steps are:

  1. Set up the first disk in a RAID array and set the second disk up as “damaged” or “disabled”.
  2. “dd” the system from the old disk to the RAID array disk.
  3. Set the old disk up as the second disk in the RAID array and let the system repair it.

I don’t think it’s complicated, but it is time-consuming.

Thank you for that…

Have tried to do that. The automated installer completely wipes the drive and reconfigures the system to a non raid mode when I run it. If I create the raid and invoke “Custom Sangoma OS7 Install” it to seems to go through the automated processes again with no option for me to make any chooses except for setting the root pass code, again re-setting the drive settings.

Perhaps I am missing a step, I am not aware of.

Again thanks…

Would not the “dd” overwrite raid con-fig files etc… Believe it would require me to coble a working system back together again. Had hoped for a simpler answer such as install minimum build, perform yum update, yum install or have some way of manually configuring the drives before I start the installer.

I can always do a manual install on a stock Centos 7 install, have done that before however that means asterisk would need to be downloaded, re-compiled and installed for updates etc… Would rather avoid that.

Yes, this is a known issue, and will be fixed in the next release of SNG7 (which should have been a couple of weeks ago, but has been held back for unrelated issues).

I’ll rebuild the latest ISO and send you a link in a few minutes, which SHOULD work.

Edit: Have sent him a link. If anyone ELSE feels like testing the new ISO (unofficially) feel free to send me a message!

xrobau, thanks for replying. I’ve just spent a bit of time on virtualbox trying out various options. There certainly does not seem to be any clean way to do this as is.

Thanks for all the suggestions.

Wanted to update the situation, xrobau sent me the iso, everything looked good. I could customize the drive configurations before the install as needed. However the the new 1703 ISO error’s out no matter what I do (attempted 4 or 5 different install options including fully automatic). This error always occurred while installing php56w-common package 402/630. Tested the system hardware fully (several live distro’s) no issues.

Any other suggestions would be extremely appreciate.

Thanks and have a great day…

The PHP issue is still raising it’s head. I’ll look at it this afternoon (my time), hopefully.

Any luck on ths xrobau? Pretty much at a standstill here. I cannot even make use of the stable
10.13.66-64bit, since it does not have the necessary drivers to support the hardware…

Again thanks…

I finally got a chance to look into it, and I’m in the process of building a new php RPM (takes about an hour), and then I’ll be able to build a new ISO for you to test.

Sorry for it taking so long, I’ve been massively busy 8-(

Wanted to update everyone… The new ISO worked fine. A caution, If you need to perform a custom install you literally have 1 second to chose your option after the initial centos 7 install splash screen first appears. If missed the automated installer takes over and you cannot make any changes.

Again thank you for every one for all the help especially xrobau