FreePBX | Register | Issues | Wiki | Portal | Support

iSymphonyV3 not working in Distro SNG7-FPBX-64bit-1707-1


(Andrew Marba) #1

Hi All,

I have installed FreePBX Distro SNG7-FPBX-64bit-1707-1 and cannot get iSymphonyV3 to work.
Error i ADMIN > iSymphony Panel :
Failed to contact the iSymphony server.

when tried to start the service from CLI the error is :
[root@freepbx ~]# service iSymphonyV3 start
Redirecting to /bin/systemctl start iSymphonyV3.service
Failed to start iSymphonyV3.service: Unit not found.

Tried to remove and re-install from admin module.

What should be done??


iSymphony on distro 14.0.1.14
(Lorne Gaetz) #2
yum list isymphony*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Available Packages
iSymphonyServerV3.noarch
iSymphonyServerV3-fpbx.noarch                    

If necessary, install with:

yum install iSymphonyServerV3-fpbx

Configure with:

/opt/isymphony3/serverconfig.sh
First, We need to know the path to your
Sun Java installation [/usr/java/latest]:
/usr/lib/jvm/jre-openjdk/
Checking for Java Binary /usr/lib/jvm/jre-openjdk//bin/java..

Start/stop/restart the service with:

/opt/isymphony3/server/iSymphonyServer.sh stop
Stopping iSymphonyServer... Done
/opt/isymphony3/server/iSymphonyServer.sh start
Starting iSymphonyServer... Done
/opt/isymphony3/server/iSymphonyServer.sh restart
Stopping iSymphonyServer... Done
Starting iSymphonyServer... Done
See /opt/isymphony3/server/log/iSymphonyServer.out.log for more details

Edit #1 - I’m not sure the userman integration is working as expected.

Edit #2 - if there was an issue with userman sync, it’s long been fixed.


Can't SSH, and no longer have access to iSymphony
(Andrew Marba) #3

Hi All,

Tried several times to re-install the iSymphony module from the module admin but no luck.
Finally installed through CLI :

yum install iSymphonyV3

AND

Changed the JAVA_HOME Environment in config-vars.sh to /usr/lib/jvm/jre-openjdk/

Now its working fine. Seems that the Module admin does not install the iSymphony server properly because when I checked the /opt folder it was empty prior to installing from cli.

Hope this might be helpful to someone.

Regards,
Andrew


(Scott P) #4

Thanks for the help.


(Kashif Sattar) #5

Error:
Failed to start iSymphonyServer.service: Unit not found.

Solution in Steps:

1)Go to the Following Path

/opt/isymphony3/server

2)Edit config-vars.sh

3)comment existing statement and Add the following Statement like below
#JAVA_HOME=/usr/java/latest
JAVA_HOME=/usr/lib/jvm/jre-openjdk/
Save it.

4)give you the start script permission on cli like following

chmod +x /opt/isymphony3/server/startup.sh

5)Finally Run the Server with given command

/opt/isymphony3/server/startup.sh

on Success you will see following message

Starting iSymphonyServer… Done

enjoy…!