iSymphony Module Reload Hangs

The FreePBX distro GUI is locking up after I install FreePBX module for iSyphmony.

Here is my install process:

# yum install iSym*

Installed:
  iSymphonyServer.noarch 0:2.2.0_2227-1

Complete!
[[email protected] ~]# cd /opt/isymphony/server/
[[email protected] server]# ./config.sh
First, We need to know the path to your
Sun Java installation [/usr/java/latest]:

Checking for Java Binary /usr/java/latest/bin/java..
[[email protected] server]# ./startup.sh
Daemonizing

I then navigate to the modules administrator. Choose upload modules. Locate and upload the isymphony-1.0.18.tar.gz. I then locate and choose to install the module.

The following is displayed:

Please wait while module actions are performed

Creating "isymphony_location" Table....
Populating(New) "isymphony_location"....
Done
Creating "isymphony_users" Table....
Populating(New) "isymphony_users"....
Done
Creating "isymphony_queues" Table....
Populating(New) "isymphony_queues"....
Done
Creating "isymphony_conference_rooms" Table....
Populating(New) "isymphony_conference_rooms"....
Done
isymphony installed successfully

After clicking the return option, I am back at the FreePBX GUI. I am able to navigate the iSymphony module, and see the status as UP, running version iSymphony v2.2.0 rev 2227.

I then added the following line to /etc/amportal.confg

After clicking the reload button the following is output

[2011-04-26 09:42:38] NOTICE[6553]: manager.c:2260 authenticate: 127.0.0.1 tried to authenticate with nonexistent user 'isymphony' [2011-04-26 09:42:38] NOTICE[6553]: manager.c:2297 authenticate: 127.0.0.1 failed to authenticate as 'isymphony'

Has anyone made it past this point?

Mike,

any chance of having a look at the way module processes things during a reload as I’ve heard from a lot of people that it can be really slow and I’m wondering if there might not be some tweaks or ordering that could be done that might give a big performance boost to the delays?

I don’t believe that the manager connection is the issue here. I think you are simply seeing those errors in response to the fact that the manager connection is not configured.

If you have a large amount of extensions configured in your system the module can take quite some time to run and populate the iSymphony config especially on the 1st run. This may make it look like the the FreePBX reload is freezing. Give it some time especially if you have a large amount of extensions. Also upping the execution timeout flag in php.ini to a larger value and then restarting apache may help the issue.

Mike Yara
i9Technologies

Yes Asterisk API is installed (v2.9.0.2).

No there are no users listed on the right side.

Ok well something went wrong with your module install. What version of their module are you using. I just tested it and it worked fine for me.

I used 1.0.18

It appears to be a issue with the iSymphony module with FreePBX 2.9. I will point the guys from i9 at this thread so they can fix there module.

Do you have the Asterisk API module installed. This is required for iSymphony to work. Also go to that module and see if on the right side it list a iSymphony user

I retried installation without modifying the /etc/amportal.confg file.

Same result. System hangs on reloading after installation of the module. Same authenticate errors in asterisk.

I am missing something? Anyone else able to duplicate?

NO do not add that line to amportal.conf. That has not been needed for years. The module handles the reload automatically now.

We don’t use iSymphony but when we reload FrePBX the GUI hangs too. We have a lot of extensions and outbound routes with custom context and the problem started when we added a very large outbound route. I would guess the issue is related and you probably also have a lot of extensions and/or a lot of routes. Unfortunately I don’t have a fix.