iSymphony external access

configuration
Tags: #<Tag:0x00007ff2e9bfbf38>

(United States) #1

I have a FreePBX appliance from Sangoma, All packages including the OS are up to date. We purchased a license for iSymphony and everything works pretty much as expected internally.

However, when attempting to access the iSymphony dashboard from outside our network, even through a VPN, the pages fail to load. The UCP is accessible, just not iSymphony. The addresses for the VPN are in the firewall and I have even attempted to disable the firewall completely to test and it makes no difference.

Any ideas would be appreciated.


(Communication Technologies) #2

http://docs.getisymphony.com/display/ISYMDOCS/Connecting+To+The+Client+Interface

Are you routing to the correct port traffic from the router?


(United States) #3

Yes, and there is nothing that would block port 58080 tcp or udp between the two. The VPN is a router, that is using OSPF and has full adjacency to the router that the PBX is connected to, I can ping it from that router just fine. There are no meaningful firewalls between the VPN router and the PBX.

Furthermore, I can ping using the URL, so it’s not a DNS issue, and directly via the PBX IP address while connected to the VPN, so IP routing is correct. In the routers, I can see the traffic hitting port 58080 and I explicitly allowed it in each firewall on the routers just in case, but it still isn’t coming up.


(Communication Technologies) #4

What about the FreePBX firewall? Is that off as well? A wireshark could help you narrow down where the breakdown is happening.


(United States) #5

Okay… I’m really stumped now. I connected through my phone (to get external access to my laptop via personal hotspot, then VPN on the laptop), then I disabled the PBX firewall and it worked, it let me in. So I re-enabled it just to verify that it would block me again and I can still get in now. I’ll try again once I get home tonight just to verify that it’s working from there, but that’s just odd.


(Dave Burgess) #6

Sounds like you got temporarily blacklisted. Turning the FW off then back on clears the temp lists.

Check your “local network” settings and make sure you don’t mess up the password when you try to connect.