Issues with FreePBX 16 Beta

Hello,
when I open the webinterface with Firefox 93.0 I see a lot of red errors on every page shift with the latest FreePBX 16 Distro (12.7.8-2109-3.sng7).
Example:

Additionally there seems to be an Issue with the Digium Addons Module as I can´t update it.

Downloading and Installing digiumaddoninstaller
Downloading digiumaddoninstaller
Installing digiumaddoninstaller
Untarring…Done
This Module Requires The Digium RPM to be installed (php-digium_register-3.0.5-1_centos6.i686.rpm). Please see this page for more information: Log In - Documentation installing digiumaddoninstaller:

Failed to run installation scripts

I did what was specified under the link (yum install -y php-digium_register) but the problem persists.

When I run fwconsole chown there is some error too:

PHP Warning: PHP Startup: Unable to load dynamic library ‘digium_register.so’ (tried: /usr/lib64/php/modules/digium_register.so (/usr/lib64/php/modules/digium_register.so: undefined symbol: _zval_copy_ctor_func), /usr/lib64/php/modules/digium_register.so.so (/usr/lib64/php/modules/digium_register.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

Best regards,
Afox

The module is long deprecated and not supported on 16.

And why is it listed then?

Its not installable from mirror, and if upgrading from 15 it will block the upgrade until it’s removed. How did you get it?

I installed from this iso: https://downloads.freepbxdistro.org/ISO/SNG7-PBX16-64bit-2109-3.iso

How can I remove "pbdirectory " and “speeddial” modules?
I do not see these two modules in “Module Admin”

fwconsole ma delete pbdirectory speeddial

There may be dependencies on these modules so take a look at the console while that command runs

I am trying to upgrade but cannot solve the “Digiumaddoninstaller/Digium_phone_module are deprecated / not supported in PBX 16+ systems. Please uninstall these modules before continuing with the PBX upgrader.” problem. Already removed the module “fwconsole ma delete digiumaddoninstaller”

And did to also remove the Digium Phones module?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.