Issues on getting Obi110 to work as FXO

I am having an heck of an time to get Obi110 to work as FXO I have the trunks setup and when I look at obi110 I am getting “Register Failed: No Response From Server (server=; retrying)” or 401/403 settings. I have tried to change ports from 5060 to 5160 that didnt work and I am using freepbx: FreePBX and I have tried this peer settings:


in the outbound trunk settings and that doesnt work either so I am about ready to give up unless somebody knows what I am doing wrong here…


ITSP Profile:

ProxyServerPort: 5160
RegistrarServerPort: 5160

SPx Service:

AuthUserName: OBiTRUNK1
AuthPassword: password123

If the PBX and OBi are not on the same subnet of the same LAN, please explain your networking setup, including make/model of any routers or firewalls in the path.

So Stewart your saying in order to make this work correctly they have to be on same subnet?

Absolutely not. My OBi110 is behind a NAT in Paris registering to a FreePBX hosted in Los Angeles.

But you said that registrations aren’t getting through, an obvious possible cause is a networking issue, so I asked you to describe your network in some detail.

Are you using your OBi110 as an trunk coming in from phone line or how are you using yours? I even have the firewall turned off on the freepbx I figured it was causing the issue and still having issues with it not registering.

I am using the FXO port as a trunk, for both incoming and outgoing calls. Primary use is answering the Paris phone (pseudo-POTS from ISP) when we are elsewhere. The FXS is presently unconnected, though it was used in the past and didn’t cause any trouble.

Run tcpdump on the PBX and see if any registration attempts are coming in. This captures ahead of the FreePBX firewall.

If nothing is coming in, set X_SipDebugOption for SPx (and set up syslog properly), to see what the OBi is sending out and where it’s sending it. If you see the right stuff going out and nothing received at the PBX, you have a networking issue. Please describe the devices in the path.

Can you post your config file how you got your trunk setup as FXO I think I am missing something here on my end and like you said it could be an network issue so I am trying get this squared away my setup now is that everything is behind an miktroik router and my freepbx is on 192.168.60.x subnet and the obi110 is on same miktroik router but on 192.168.92.x subnet I am going try to see if I move the obi to same subnet as my freepbx see if it connects.

This is what I am getting right now
Register Failed: No Response From Server (server=; retrying) after I moved the obi110 onto the same subnet as the freepbx

after switching to 5060 getting this:
[2020-03-10 22:48:18] NOTICE[14258]: res_pjsip/pjsip_distributor.c:368 log_unidentified_request: Request from ‘sip:[email protected]’ failed for ‘’ (callid: [email protected]) - No matching endpoint found

The pjsip error is exactly what was expected.

For the chan_sip issue, confirm that in Advanced Settings, SIP Channel Driver is set to both, and in Asterisk SIP Settings -> chan_sip, Bind Port is set to 5160. Of course, the OBi ProxyServerPort and RegistrarServerPort must both be 5160.

When you change any of the above, restart (not just reload) Asterisk and then restart the OBi so it attempts registration again.

If you still have trouble, report what appears in the Asterisk Log when the OBi attempts to register. If nothing, run tcpdump on the PBX to see whether any registration requests are arriving there.

Under Advanced General Settings blind port its showing 5061 noting with 5160 So I am changing the blind port to 5160 right now see if it changes anything then restarting asterisk.

I finally got the obi to register

I got the outbound to work but still needing get the inbound to work correctly

Confirm that InboundCallRoute for the Line port is set properly.

When you call in, what appears in the Asterisk log? If nothing, what shows in the OBi’s Call History? What does the caller hear?

Stewart I got everything working correctly and I must stay thank you so much for helping out. But other thing I am missing the CID when the number rings in it just say Obitrunk1 in caller ID

For the ITSP Profile -> SIP, X_SpoofCallerID should be checked.

If that’s not your issue, does the correct CID show in the OBi’s call history?

If yes:
At the Asterisk command prompt, type
sip set debug on
make a test call, paste the relevant portion of the Asterisk log at and post the link here.

If no:
What country are you in? What is the OBi Line port connected to (copper pair from central office, cable MTA, fiber router or ONT, etc.)?

Stewart I am connected to lovely cable (MSO) eMTA modem so I am going try that setting switch like you just said.

Just an update after making that switch it worked thanks again Stewart for all your help bud!!!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.