Issue with updating the XMPP module


(Daniel Friedman) #21

Hi @admin321,

It seems that your MongoDB is not installed. Furthermore, I think that you have connectivity problems. You should check that as well.
Try to run the yum commands again (update and complete transactions) and report back.

Thank you,

Daniel Friedman
Trixton LTD.


(Kate) #22

Hi Daniel,

Please, find the report.

https://pastebin.ca/3933909

Thank you!

Kate


(Daniel Friedman) #23

Hi @admin321,

OK, it seems that you updated your RPMs. Now, try to install the XMPP module like that:
fwconsole ma update xmpp

Thank you,

Daniel Friedman
Trixton LTD.


(Kate) #24

Hi Daniel,

Please, see result:

[root@freepbx ~]# fwconsole ma update xmpp
No repos specified, using: [extended,standard] from last GUI settings
Downloading module 'xmpp'
Processing xmpp
Verifying local module download...Verified
Extracting...Done
Download completed in 6 seconds
Installing/Updating MongoDB...MongoDB is not installed
Unable to install module xmpp:
- Failed to run installation scripts
Updating Hooks...Done
Updating Hooks...Done
[root@freepbx ~]# 

Kate


(Daniel Friedman) #25

Hi @admin321,

Please install the mongodb-server RPM:
yum install mongodb-server

After the installation run the xmpp installation again:
fwconsole ma update xmpp

Thank you,

Daniel Friedman
Trixton LTD.


(Kate) #26

Hi Daniel,

All is fine now. Thank you so much!

Kate


#27

Daniel, I had the same problem. your post fixed the problem. Thank you