Issue with Outbound Configuration

Hello: I am having a problem configuring outbound dialing in my FreePBX 2.4.1.0 instance. I am running a vanilla installation on Debian. Inbound calling works fine, however, for some reason I am not able to place outbound calls. When I try to place an outbound call, I immediately get ‘Your call cannot be completed as dialed’. I’ve checked to make sure that my firewall is allowing traffic bi-directionally on 5060 and 5061, and I’ve played around quite a bit with my trunk configuration. I’ve included most of my configuration below as well as the CLI output when a call is placed, however if there is anything else I can provide, please let me know. I’ve worked on this for a few days without luck. If anyone has any suggestions, please let me know.

##Here are my outbound dialing rules##:
1|NXXNXXXXXX
NXXNXXXXXX
NXXXXXX

##Here is my Trunk Peer Details##:

username=myusernamewenthere
secret=mypasswordwenthere
host=stl04a.netlogic.net
dtmfmode=rfc2833
insecure=invite,port
context=from-trunk
type=peer
fromuser=myusernamewenthere
authuser=myusernamewenthere
canreinvite=no
qualify=yes
disallow=all
allow=alaw&ulaw

##Here is some of my extensions.conf configuration##:
[from-internal]
include => from-internal-xfer
include => bad-number

[from-internal-xfer]
; applications are now mostly all found in from-internal-additional in _custom.c
onf
include => parkedcalls
include => from-internal-custom
;allow phones to dial other extensions
include => ext-fax
;allow phones to access generated contexts

##Here is the CLI output when a call is dialed##:

— (13 headers 0 lines) —
Scheduling destruction of SIP dialog ‘[email protected]’ in 32000 ms (Method: REGISTER)
– Executing [[email protected]:4] Playback(“SIP/2860-087abcb8”, “silence/1&cannot-complete-as-dialed&check-number-dial-again|noanswer”) in new stack
– <SIP/2860-087abcb8> Playing ‘silence/1’ (language ‘en’)
– <SIP/2860-087abcb8> Playing ‘cannot-complete-as-dialed’ (language ‘en’)
– <SIP/2860-087abcb8> Playing ‘check-number-dial-again’ (language ‘en’)
– Executing [[email protected]:5] Wait(“SIP/2860-087abcb8”, “1”) in new stack
– Executing [[email protected]:6] Congestion(“SIP/2860-087abcb8”, “20”) in new stack
== Spawn extension (from-internal, 16466885555, 6) exited non-zero on ‘SIP/2860-087abcb8’
– Executing [[email protected]:1] Macro(“SIP/2860-087abcb8”, “hangupcall”) in new stack
– Executing [[email protected]:1] ResetCDR(“SIP/2860-087abcb8”, “w”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/2860-087abcb8”, “”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/2860-087abcb8”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,6)
– Executing [[email protected]:6] GotoIf(“SIP/2860-087abcb8”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] GotoIf(“SIP/2860-087abcb8”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,11)
– Executing [[email protected]:11] Hangup(“SIP/2860-087abcb8”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘SIP/2860-087abcb8’ in macro ‘hangupcall’
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on 'SIP/2860-087abcb8’
ARDBEG*CLI>

##Some more CLI output with IP debug##:

Reliably Transmitting (no NAT) to 206.80.67.34:5060:
OPTIONS sip:stl04a.netlogic.net SIP/2.0
Via: SIP/2.0/UDP myip:5060;branch=z9hG4bK1ac3fd9b;rport
From: “Unknown” sip:[email protected];tag=as08785b3c
To: sip:stl04a.netlogic.net
Contact: sip:[email protected]
Call-ID: [email protected]
CSeq: 102 OPTIONS
User-Agent: Asterisk PBX
Max-Forwards: 70
Date: Thu, 12 Feb 2009 17:28:24 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Content-Length: 0


ARDBEG*CLI>
<— SIP read from 206.80.67.34:5060 —>
SIP/2.0 200 OK
Via: SIP/2.0/UDP myip:5060;branch=z9hG4bK1ac3fd9b;received=myip;rport=5060
From: “Unknown” sip:[email protected];tag=as08785b3c
To: sip:stl04a.netlogic.net;tag=as48c6e8e4
Call-ID: [email protected]
CSeq: 102 OPTIONS
User-Agent: NetLogic Switch v3.2.3
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Contact: sip:206.80.67.34
Accept: application/sdp
Content-Length: 0