Issue with internet access

Got a strange issue that has me stumped.
I have a FreePBX system on a proxmox system. All was working okay until I had to move the whole lot from my setup lab to the customers site. My issue is that I cannot get freepbx to access the web. I cannot ping 8.8.8.8. I can however ping other local IP addresses including IP’s down a vpn tunnel. Now before anyone says its a firewall issue I have a simple Ubuntu server I spun up using the same network on the proxmox system and it can ping anything.
Freepbx details are.FreePBX 16.0.40.8
IP 10.2.1.5
gateway 10.2.1.1

[root@pbx ~]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 10.2.1.1 0.0.0.0 UG 0 0 0 eth0
10.2.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1002 0 0 eth0
[root@pbx ~]#

Any suggestions would be great.

Richard.

Could be Route settings keeps cash try to Flush and reboot your VM.

ip route flush table main

from the pbx box can you do perform a nslookup to tthe dns server or any other servers?
can you ping other extenal addresses from that pbx box?

before saying its not the firewall… are outbound ports blocked by chance? (our MSP has all outbound ports blocked, and have to be opened as needed – took me a few days to figure this out when I started with the org.)

Thanks for the suggestion. After I did that flush i cannot ping anything, just itself. Before I could ping anything on the local LAN and down VPN tunnels but not out to the web.

Just a heads up on this I found an error.
If I did a systemctl restart network I get this error.
'Job for network.service failed because the control process exited with error code. See “Systemctl status network.service” and “journalctl -xe” for details.

Systemctl status network.service shows this error line
Failed to start LSB: Bring up/down networking

Doing a journal -xe shows a line
/etc/sysconf/network-scripts/ifup-eth[3549]: Device name does not seem to be present.

That file does not exist in the folder, and does not exist on the new FreePBX system I spun up on the same Proxmox server.

Also I have checked the Sonicwall firewall and there are no blocking outbound rules. I checked by setting the IP address of a test VM to 10.2.5.1 and it can access the web.

What do I do to fix this LSB error? Can I just creat a empty /etc/sysconf/network-scripts/ifup-eth[3549] file?

Everytime I try restarting the network this file name changes???
/etc/sysconf/network-scripts/ifup-eth[4508]
/etc/sysconf/network-scripts/ifup-eth[5251]

I can’t seem to find a solution to fix it. Everything says to check various things but does not specifically say what to do.

I spun up a new proxmox VM with FreePBX. It does not have this issue in accessing the web.
Maybe I should try to restore a backup to it? But that is a headache in itself!

As root with lshw installed

lshw -class network -short

should identify the names used by the running kernel, upgrading because it’s Tuesday, can leave udev with a file

/etc/udev/rules.d/70-persistent-net.rules

that might have aliased things you thought you knew.