Issue with custom contexts in Freepbx 2.9.0.12 / Asterisk 1.4.43

Folks,

I’m having an issue with one of our customer, it is a supermarket and we have a few extensions under a custom context that they can not dial out with out using a PIN number, that is working perfect, also they are able to dial local extensions.

the issue is that i have a Paging group setup with Extension # 15 on those phones when i dial 15 the page did not go thru and i got the fail over.

Basically on my custom context i have all the option to ALLOW including my DialOutPIN Route, only this options are Deny:

ENTIRE Basic Internal Dialplan
ALL OUTBOUND ROUTES
AllOut-CV (this one is my main route)

How can i acomplish to set those phone to use the paging feature.

This is the log when i dial ext/paging 15, i see that is try to dial using the DialOutWithPin trunk instead from-internal :

Connected to Asterisk 1.4.43 currently running on AS-pbx (pid = 2783)
Verbosity is at least 3
– Executing [[email protected]:1] ResetCDR(“SIP/300-00002f53”, “”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/300-00002f53”, “”) in new stack
– Executing [[email protected]:3] Progress(“SIP/300-00002f53”, “”) in new stack
– Executing [[email protected]:4] Wait(“SIP/300-00002f53”, “1”) in new stack
– Executing [[email protected]:5] Progress(“SIP/300-00002f53”, “”) in new stack
– Executing [[email protected]:6] Playback(“SIP/300-00002f53”, “silence/1&cannot-complete-as-dialed&check-number-dial-again|noanswer”) in new stack
– <SIP/300-00002f53> Playing ‘silence/1’ (language ‘en’)
– <SIP/300-00002f53> Playing ‘cannot-complete-as-dialed’ (language ‘en’)
– <SIP/300-00002f53> Playing ‘check-number-dial-again’ (language ‘en’)
– Executing [[email protected]:7] Wait(“SIP/300-00002f53”, “1”) in new stack
– Executing [[email protected]:8] Congestion(“SIP/300-00002f53”, “20”) in new stack
== Spawn extension (DialOutWithPin, 15, 8) exited non-zero on ‘SIP/300-00002f53’
– Executing [[email protected]:1] Macro(“SIP/300-00002f53”, “hangupcall|”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/300-00002f53”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] GotoIf(“SIP/300-00002f53”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,5)
– Executing [[email protected]:5] GotoIf(“SIP/300-00002f53”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [[email protected]:7] Hangup(“SIP/300-00002f53”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 7) exited non-zero on ‘SIP/300-00002f53’ in macro ‘hangupcall’
== Spawn extension (DialOutWithPin, h, 1) exited non-zero on ‘SIP/300-00002f53’

Thanks in advance

Did I read your post right?

Basically on my custom context i have all the option to ALLOW including my DialOutPIN >Route, only this options are Deny:

ENTIRE Basic Internal Dialplan
.
.

If you chose to deny the EnTIRE Basic Internal Dialplan, why are you surprised that the call is not using the [from-internal] context (DialPlan) which includes th paging functionality ?

When i allow the ENTIRE Basic Internal Dialplan, for some reason the rules are not applying, they can make outbound calls and it is not restricting the others trunks.

That is why there are so many caveats about using that module. It is certainly not for the faint of heart, the weighting and the order of inclusion need a certain depth of understanding. I suggest taht you should carefully read through ALL the /etc/asterisk/extension*.conf files to fully understand how the module abstracts those contexts, hopefully then you will understand how it all works.

Perhaps isolating your paging context into a custom context would be enough in this particular case. This can be done with or without using the custom contexts module.

http://voip-info.org is a good source of how you might go about doing that, it’s worth the effort.

God Luck, :slight_smile:

Ok. Thank you,

i will restrict the caller using the CallerID feature on the outbound route, that should do the job for me now.

:slight_smile: