Is there any way to install a VPN server on Asterisk?

I am planning on adding a remote extension and I want to limit my exposure to the public internet. As such I would like to connect to the PBX using a VPN. Is there a way to natively add VPN support directly to FreePBX, or do I need to do so via another piece of hardware?

However, not all end devices can use that. Some routers can and a few phones such as the Snom 370 support OpenVPN natively.

Very true, however I confirmed that the one device I will use as a remote extension (Android device) does natively support OpenVPN.

Well, there you go.

If only iOS supported OpenVPN :frowning:

So my question is there any way to install openVPN on FreePBX. I would like to avoid adding another piece of hardware if possible.

Absolutly! I have Open VPN installed on all my servers. I build a VPN tunnel from each server back to my head end at the corporate data center. I use the VPN for management and backups.

Are you running a Linux box or is it windows? If Linux, how did you set it up to run both FreePBX and OpenVPN on the same machine?

OpenVPN is already installed if you did your FreePBX install from the distro. If you build you system by hand you will need to install OpenVPN with yum or whatever package manager you are using.

That is excellent news, thanks! I did use a distro so I am assuming that means I have OpenVPN already. How do I access the settings since I dont see them anywhere in the admin panel.

There are no options in the FreePBX GUI to setup OpenVPN. You will have to go to the OpenVPN site and read the docks on how to set it up.

Will do. Before I do that, do you know how I would verify if it is installed yet? I am not that handy with CLI, so I cant figure out the commands to find the program.

You indicated “a” distro install… Is that the FreePBX Distro ?

Also, configuration of OpenVPN would be by command line interface and if you are not comfortable with that then you would be better off using using a router that supports the same VPN method -or- type as your remote device if possible. Most soho routers that support VPN do configuration in their GUI and that might be less of a learning curve.

If you run this command it will tell you what packages are installed.

rpm -qa

This will filter all that output and just look for openvpn

rpm -q | grep openvpn

I tried both of those commands and neither worked. Here are the results I got.

PlugPBX:~# rpm -qa
-bash: rpm: command not found
PlugPBX:~# rpm
-bash: rpm: command not found

Any suggestions?

You are sure you did a FreePBX install from the distro install disk you downloaded from the site?

Thats actually a good question so I went back to check. Since I installed FreePBX on a small embedded device I actually flashed a custom build from PlugPBX. You can check the downloads section from the link below, and the one I used was the windows version. They dont specify the contents so I am wondering if OpenVPN was included. Is there not an easy way to check?

You sure could have saved a lot of time if you had told everyone that you were using a Shiva appliance and Plug PBX. If you read the “welcome to FreePBX sticky’s and how to ask for help” this is why we always ask you to tell us about your system.

The guys helping you are very kind gratious folks and probably won’t share the frustration that occurs when they could have been helping you.

Now that I have that off my chest, this is a debian based system and an entire different animal than anything you read about here.

For now you need to be very careful as almost everything written for FreePBX is on Redhat/CentOS systems. PlubPBX uses Debian and a CramFS (Flash File system. Most of what you read will break your system. Also you won’t be able to upgrade past 2.9 via module admin in FreePBX until the PlugPBX make some PHP updates to support this. It’s not something that an end user would be able to do as you have to be very careful with the limited space on the RAM drives on that system.

Also of note is the PlugPBX is Debian not Redhat based.

The only good news is it supports Webmin. I could not find any immediate results on OpenVPN and plugPBX.

Now you have some more knowledge.

My mistake, I should have clarified the system details of what I have in place. However, if anyone with Debian experience can comment further it would be greatly appreciated.

For debian:

To list installed packages: dpkg -l

To list installed packages and search for one with VPN in the name: dpkg -l | grep -i vpn

To install openvpn via package manager: apt-get install openvpn

That might help you for now, but it sounds like your current setup may be short lived since it can’t be upgraded a past 2.9.

Hope this helps, though.