Is fwconsole trunk broken for anyone else

Updated a system this evening and then rebooted it. All running normal, well except But that is not FreePBX’s fault.

So I wanted to disable the trunk, just in case some services upstream were working and my failover would kick in. Unlikely, I know with all of their issues, but meh.

I hopped back on and ran fwconsole trunk with the result that it did not do jack. This is a first.

This is everything that was upgraded:
My script does a yum upgrade -y

Then a fwconsole ma upgradeall

Full log of the upgrade.

fwconsole trunk --help
fwconsole trunk --list
fwconsole trunk --disable 9
fwconsole reload
fwconsole trunk --list


Yesterday (and all days prior) you do not have to pass any parameters. You can just call trunk and get this menu and select one and then it toggles it and tells you to reload.

Like this:

This system is on core so I guess I can upgrade and see what happens.

Edit: nope still works normal, including always saying “disabled” even though it is a toggle.

Perhaps you ‘don’t have to’, but if you do pass --enable/–disable , then it would not be a ‘toggle’, which is what I prefer.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.