IPTables Disable

I am trying to disable iptables. I am behind a router a firewall already and dont believe i need it. I would like to just tell iptables to allow EVERYTHING.

Is this whan i need to do step by step:
iptables -F
iptables -A INPUT -i lo -j ACCEPT
iptables -A OUTPUT -o lo -j ACCEPT
iptables -A INPUT -i eth0 -j ACCEPT
iptables -A OUTPUT -o eth0 -j ACCEPT
iptables save

Thank YOU!

If you want it completely disabled just stop the service:

service iptables stop

To stop it permanently:

chkconfig --level 345 iptables off

ANother question,

That was my first thought. service iptables stop and chkconfig --level 345 iptables off … however when i boot up and run service iptables stop again to see if its disabled it shows it stopping? It shouldnt be started? chckconfig --list shows it off? I was wondering if fail2ban is turning it back on?

Thank You

Try going into the system admin module and stop it there.

If you don’t want iptables then there isn’t much point in running fail2ban either as that uses iptables as part of it’s banning mechanism. You can stop this in a similar way to iptables (e.g. with chkconfig).