iPhone will not connect only shows registering


(United States) #1

I have Sangoma Connect setup and running on my Freepbx. The SangomaConnect and CloudConnect Agent Status are both Running. I’ve sent an invite and it does show in the Authentication Status “Authenticated.” On the iPhone, it just has in the upper left-hand corner marching ant going around the extension number. When I tap on the extension number it keeps saying registering. It never connects.

In the Sangoma Connect Module it says:

CloudConnect Agent will securely connect SangomaConnect server running on the PBX to the Sangoma Cloud, in order to facilitate remote user control.

With CloudConnect agent running, a permanent secure websocket connection to Sangoma Cloud and will allow remote users, with specific permissions to access SangomConnect service.

CloudConnect, enables ability to provision SangomaConnect mobile apps without requiring to open a public port within the corporate firewall.

I’ve read on the forums here that people had to open 5060 TCP/UDP. I don’t want to open any ports.
As to the information that the CloudConnect says you don’t have to open any public port with the firewall.
Any information on how to get this working with opening ports would be greatly appreciated.


(Defcomllc) #2

Mine runs great and I do have my PJSIP UDP Bind port opened and forwarded to my FreePBX server…works.great and Sangoma connect works great. I don’t use the default bind port…


(Defcomllc) #3

Also there are Sangoma IP’s to whitelist for this traffic.


(United States) #4

Sangoma Connect is supposed to work without opening any ports. If that is the case then Sangoma Connect is like every other softphone.


(Lorne Gaetz) #5

Sangoma Connect must have an IP route to the PBX, so if you’re connecting thru a NAT router/firewall, then it MUST be configured to forward SIP and media to the PBX. The PBX Firewall must also be configured to allow the inbound signaling.


(United States) #6

Could you explain why in the Sangoma Connect Module it says this?
“CloudConnect, enables ability to provision SangomaConnect mobile apps without requiring to open a public port within the corporate firewall .”


#7

You are not opening a port to the public, only to a trusted source. If you don’t trust Sangoma you shouldn’t be using PBX, because you are already trusting them for system and software updates.


(Richard Smith) #8

There are two parts to this, provision which you can lockdown the ports to the Sangoma IP’s and then registration, which if you are using your Cell network means you are unlikely to have static IPs. So you will need to open your SIP port to the outside world, which if you enable responsive firewall will be fine.


(United States) #9

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


(Lorne Gaetz) #10

In case the above does not clarify, provisioning and registration are separate operations. You can provision the client without exposing a provisioning port on your PBX, but the SIP registration relies on a route to a SIP signaling port just like any other SIP client.