Iotserver (

My version 14 and 15 systems recently had in the Dashboard a notification that a new module is available that being iotserver ( After running the check updates, I scoured the modules and never found iotserver ( I ensured that all of the module types, Commercial, Extended etc., were all checked and ran it again. Scoured the list of modules and again I never could find iotserver (

As a second point, I STFed iotserver in these forums and didn’t find but three posts and none seemed to have nothing to do with this issue. I checked the Wiki and found nothing.

Is this vaporware? What is it? Where can I find documentation and why am I so blind or stupid that I can’t find it as an available module. A lot of other stuff comes as available online but not iotserver (

What in the world am I doing wrong? Do I need to enable another repository? My 15 system is also running in Edge mode. I have a 14 distro system in which I can’t find it as well. And where can I find documentation on it?



I believe it’s part of this which is not yet actually released.

1 Like

The module is called smart office and it actually is an io server. It is a commercial module. This is a good idea, but unfortunately it seems to support US-hardware only . We don’t have this type of door buckle in Europe.
My freePBX server is not in edge mode and I got it offered too…

Seems like an unusual direction for a PBX, though I am guilty of adding strange things to my PBXes as well (full-blown weather station with color maps sent to Cisco video phones…)

1 Like

The module is listed as SmartOffice and its a commercial module that is currently in Beta phase. You can find some documentation on the module here:
The module comes with a mobile app that is available on playstore and app store (Just search for Sangoma Smart Office) and it would enable access control features to your PBX users. You can Contact Sangoma Support if you want to be enrolled as a Beta tester for that module.

So this is for on-premises only? What if the PBX is in the cloud? What if you have multiple locations, I have someone with one PBX and 20 offices around NYC (all 5 burrows)? Can I control all 20 locations from a single PBX system over the Internet and through NAT?

I honestly have no idea how to feel about this because I just look around and it goes back to a comment I made in another thread here. Quality over quantity. Because based on everything over the last couple years I just wouldn’t trust this.

First, the elephant in the room to be addressed. Sangoma is breaking out this IoT solution when after close to five years of Sangoma still not having a viable solution for their HA users. So while they have been forced to sit on v13 waiting for something to happen because Sangoma refuses to admit HA is dead and they keep saying “Oh it’s coming” but instead we get this. FreePBX can be a DHCP server for your network, do wireless and they even have appliances with antennas, fancy. Still don’t have a new viable HA solution.

Second, QA is abysmal. Over the last couple years really, really dumb bugs have been released into production. Modules have been released with dependencies still not ready to be released and that causes things to break or not work right. All in all users have to deal with their PBX systems either not making calls at all, properly or not getting into the GUI because things were messed up. The last thing anyone needs is for something to happen and not having calls AND not being able to open doors or have security because the PBX is messed up due to a bug or messed up update that is missing things.

Third, Sangoma’s track record on this isn’t that great. As pointed out HA but let’s not forget that RMS debacle. Zulu, despite being version 3, still has things in Beta mode after years of being out. I mean Call Event Reporting has been in Beta since v13. Even the UCP, despite being told in Feb 2017 when v14 was in alpha that the UCP stuff would be dealt with, templates would be available and admins/users wouldn’t have to create UCP default pages for every user they have. Still ain’t got that.

I guess this is where my problem is. It just looks like a bunch of half-baked things are being pushed out and then left half-baked while Sangoma starts working on the next thing to half-bake. How come in the last five years more simple and promised things just weren’t done? Why has the UCP stuff not been done like promised? Why is CEL still in beta? Why does Zulu still have beta stuff after a year? Why isn’t there an HA solution after five years?

Please just focus on the known things that need to be fixed and completed. I know that bringing out new features and stuff is important but is it that important to build the new features on a flawed infrastructure that needs to be overhauled? You’re just making more work down the road. Stop adding technical debt to the project and deal with the expansive technical dept that already exists on the project. That would be an awesome direction to take.

1 Like

Thanks guys! I would have never connected the words or naming “Smart Office” with iotserver! That is a big help.

My homes are all sort of ‘smart’ using an isy994i for control and I have all the control that I think I need. Not certain how I feel about turning a pbx into an iot server for such but … what the heck I guess.

Thanks again!


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.