FreePBX | Register | Issues | Wiki | Portal | Support

Invalid Websocket Transport for Zulu


(Tony Guadagno) #1

Hi, I am using FreePBX 14.0.3.25 and I noticed this on the dash about 2 weeks ago and it will not go away.

It says that ws and wss are enabled but they are not…

how do i get rid of this error?

thanks in advance


(Lorne Gaetz) #2

https://wiki.freepbx.org/display/ZU/Zulu+3+Server+Installation

Browse to Settings, Asterisk SIP Settings , PJSIP tab

  • enable both “ws - 0.0.0.0 - All” and “wss - 0.0.0.0 - All”. Leave ws and wss disabled for individual interfaces.

(Tony Guadagno) #3

Lorne, thanks. I guess my question is, do I need to do this if i do NOT want to run zulu? I would rather not enable services or ports (for security reasons) for services I am not using.

thanks


(Lorne Gaetz) #4

If you need it, enable it. If you don’t need it, don’t.


#6

“If you need it, enable it. If you don’t need it, don’t”

I have completely Removed Zulu, and I STILL receive the “Critical Error” message: “Invalid Websocket Transport for Zulu”. I would like to cleanup the error messages.


(Andrew Nagy) #7

Click the red (X) and it will magically delete.


#8

I assumed it would go away on its own. Got it. Thanks.


(Andrew Nagy) #9

You uninstalled the module and never resolved the problem so no it wouldnt.