Invalid user admin?

Now I’ve done it. I’m trying to bring * up to 1.4.22 with dahdi on our Sangoma A200. I’ve rebuilt asterisk, zaptel, dahdi and wanpipe a few times while playing with configurations. I’ve no idea what I did differently but somewhere a couple hours ago I started getting an error from manager.c:

manager.c: tried to authenticate with nonexistent user ‘admin’

Whah? Of course asterisk won’t start.

The user admin with password admin is indeed in ampusers. I don’t know the code. Anyone else up late with ideas?

Okay, solved my own problem. I’d done make samples on the last asterisk build, and I assume that replaced all kinds of important things. Back to normal now.

Now running FreePBX 2.5.1 + asterisk 1.4.22 + dahdi 2.0 + wanpipe. I’m in dahdi/zap compatibility mode. In case anyone turns this up while searching, be sure to remove the semicolon from the [options] line of /etc/asterisk/asterisk.conf when adding the "dahdichanname = no " line. I hadn’t, and I could receive but not place calls. They all ended with the congestion message and the log showed zap not available. Sent me on a merry chase.

Freaking semicolon.