FreePBX | Register | Issues | Wiki | Portal | Support

"Invalid Trunk Name entered" error trying to create a DAHDi trunk


#1

FreePBX 12.0.76.6
Asterisk 11.17.1
Centos 6.10

I have to say that it has been forever since this system was initially set up. The system has been moved onto new hardware and everything is working fine other than the analog channels. My thought was to remove and re-add the analog trunk but that has turned out to be a mistake, now all the analog channels are not working.

For the time being I have dug up some ATA FXO/FXS boxes and have things sorta working but faxing, ya, old-school faxing with fax machines, is not working well as you might expect. So I’m keen to get the TDM400 back cookin’ again.

DAHDI, Asterisk and FreePBX all seem to start clean and the TDM400 appears to be there as lspci shows “Communication controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface” as expected. No apparent interrupt conflicts and the ports are lighting up as configured.

Any thoughts about how to work around this?


#2

You would have to post the trunk name of your defined dahdi trunk that is invalid, does that make sense?

Dahdi has ny default predefined G0 and g0 trunks but also 0,1,2… until you run out

dahdi_cfg -vv

would help


#3

Where do I find the actual trunk name defined? It was something like “DAHDI analog g0” and any changes to the trunk settings were being rejected with the invalid name error which led me to delete and try and recreate it…

# dahdi_cfg -vv
DAHDI Tools Version - 2.9.0.1

DAHDI Version: 2.9.0
Echo Canceller(s): MG2
Configuration
======================


Channel map:

Channel 01: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 01)
Channel 02: FXO Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 02)
Channel 03: FXO Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 03)

3 channels to configure.

Setting echocan for channel 1 to mg2
Setting echocan for channel 2 to mg2
Setting echocan for channel 3 to mg2

#4

“Something like” is not helpful, was it not you that attempted it?

maybe post some pictures if you can’t post the config explicitly


#5

I say “something like” because I don’t recall exactly what it was. It was not being accepted for changes either.

How does one determine what it should be?

I have grepped through all the dahdi and asterisk config stuff that I can find and there is no refrernce to “g0” or “G0” that I can see. Right now there is no analog channel config to post because there is none, no trunk name is accepted …


#6
*CLI> dahdi show channels
       Chan Extension       Context         Language   MOH Interpret        Blocked    State      Description                     
     pseudo                 default                    default                         In Service                                 
          1                                 en         default                         In Service                                 
          2                 from-internal   en         default                         In Service                                 
          3                 from-internal   en         default                         In Service                                 
*CLI> dahdi show status
    Description                              Alarms  IRQ    bpviol CRC    Fra Codi Options  LBO
    Wildcard TDM400P REV I Board 5           OK      0      0      0      CAS Unk           0 db (CSU)/0-133 feet (DSX-1)

#7

So any thoughts about how to resolve this? It was working fine before the computer change.

I have gone through all the configuration steps (multiple times) here:

But Freepbx still fails to “see” the analogue card so it does not accept anything for the trunk name.

What is the keystone that connects the asterisk/dahdi config with Freepbx or what does Freepbx look at to know that there is an analogue card present?

Still working on this (2019.02.11)
So to try and simulate an incoming PSTN call I connected the FXS port on the SPA-3102 (“FXS” below) to the FXO port on the TDM400 and let it ring.

Based on the result I tried to create a trunk named “DAHDI/1-1” but FreePBX dunna like that either. I work in Markham, I wonder if I went around to the Sangoma office if anyone would know the missing link :wink:

[2019-02-11 18:25:54] VERBOSE[22711][C-0000002b] app_dial.c: -- SIP/FXS-0000004b is ringing
[2019-02-11 18:25:56] VERBOSE[22720][C-0000002c] sig_analog.c: -- Starting simple switch on 'DAHDI/1-1'
[2019-02-11 18:25:57] WARNING[22720][C-0000002c] pbx.c: Channel 'DAHDI/1-1' sent to invalid extension but no invalid handler: context,exten,priority=,s,1
[2019-02-11 18:25:57] VERBOSE[22720][C-0000002c] sig_analog.c: -- Hanging up on 'DAHDI/1-1'
[2019-02-11 18:25:57] VERBOSE[22720][C-0000002c] chan_dahdi.c: -- Hungup 'DAHDI/1-1'
[2019-02-11 18:26:02] VERBOSE[22727][C-0000002d] sig_analog.c: -- Starting simple switch on 'DAHDI/1-1'
[2019-02-11 18:26:12] WARNING[22727][C-0000002d] pbx.c: Channel 'DAHDI/1-1' sent to invalid extension but no invalid handler: context,exten,priority=,s,1
[2019-02-11 18:26:12] VERBOSE[22727][C-0000002d] sig_analog.c: -- Hanging up on 'DAHDI/1-1'
[2019-02-11 18:26:12] VERBOSE[22727][C-0000002d] chan_dahdi.c: -- Hungup 'DAHDI/1-1'
[2019-02-11 18:26:20] VERBOSE[22776][C-0000002e] sig_analog.c: -- Starting simple switch on 'DAHDI/1-1'
[2019-02-11 18:26:30] WARNING[22776][C-0000002e] pbx.c: Channel 'DAHDI/1-1' sent to invalid extension but no invalid handler: context,exten,priority=,s,1
[2019-02-11 18:26:30] VERBOSE[22776][C-0000002e] sig_analog.c: -- Hanging up on 'DAHDI/1-1'
[2019-02-11 18:26:30] VERBOSE[22776][C-0000002e] chan_dahdi.c: -- Hungup 'DAHDI/1-1'
[2019-02-11 18:26:38] VERBOSE[22861][C-0000002f] sig_analog.c: -- Starting simple switch on 'DAHDI/1-1'
[2019-02-11 18:26:48] WARNING[22861][C-0000002f] pbx.c: Channel 'DAHDI/1-1' sent to invalid extension but no invalid handler: context,exten,priority=,s,1
[2019-02-11 18:26:48] VERBOSE[22861][C-0000002f] sig_analog.c: -- Hanging up on 'DAHDI/1-1'
[2019-02-11 18:26:48] VERBOSE[22861][C-0000002f] chan_dahdi.c: -- Hungup 'DAHDI/1-1'

(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.