International Calling in Free PBX Settings / Trunk

Hello! My name is Bryan and I’ve been trying to get international calling up and running for my organization for a while, and have ready plenty online about how to set up international calling, but so far, none of the things I’ve seen or tried worked. Whenever an international call is made, it simply just goes silent and says “the number is not answering”, which leads me to believe it’s hitting the trunk, and just not going out from there. Here is the current outbound route for the PBX -

As for the trunk, there is nothing currently there for 011 for international calling, so I’m wondering what settings to I need to insert into the trunk to make the international calling functionality work.

On a side note, we have to dial 81 to dial out, where would this function be located to set up the dial out code, as I’ve yet to locate it in the system. I wish to lift it, or at least set it to a single digit to see if that allows us to call out.

Current ISP/Phone provider is Spectrum Enterprise; contacted them several times, they claim there is no block, but I’ve yet to be able to dial out internationally.

If anyone has any suggestions, I would love to hear them, as I’m a bit lost on this.

You should need only one pattern.
Assuming that the user will be dialing 8+011+countrycode+number and Spectrum is expecting 011+countrycode+number, then try:

prepend: (leave blank)
prefix: 8
match pattern: 011XXXXXX.
CallerID: (leave blank)

Note the dot at the end of the match pattern. That is important because international numbers can have anywhere from 7 to 15 digits after the 011.

For example, you are calling 3026 4621 in London, UK (The Test Call), the user would dial 8011442030264621, your Outbound Route would strip off the 8 and Spectrum would receive 011442030264621.

If no luck, confirm that what is being dialed doesn’t match another Outbound Route that is earlier in the list.

If still no luck, post a log of a failing call attempt.

The thing is, we use 81 to dial out, so I would dial 81 + 011 then the number afterward. I assume I just have 81 as the prefix instead of just 8 then?

That seems strange. Are you sure the 1 isn’t part of the number being dialed. Many US landline carriers require a 1 before the area code. I don’t know whether that applies to Spectrum.

But if the user will dial e.g. 81011442030264621 then indeed setting the prefix to 81 is correct.

If you have trouble, post the dial patterns for your regular (domestic) Outbound Route.


Prepend for normal long distance looks like this. Tried the prefix for the international calling as you said, still no dice… Maybe it’s the context that’s breaking it? it tries to dial out, then it only displays part of the number on the phone, then silence, then ‘the number isn’t answering’. I have tried it with 8181xxxxxxxxxxxxxxxx. I could try it just as a . for the wild card. let me try that.

Actually, assuming that your user is dialing 81 and then a 10 digit number, then no you are not “using 81” to dial out.
Your screenshot very clearly defines what is happening here.

Line 2 there is prepending 81 is a user dials a 10 digit number on their phone. Since you claim users are dialing 81NXXNXXXXXX then that rule is never matched.

Line 3 matches 81011 and any number of digits, then strips the 8 and sends 1011 and anything dialed. This is an invalid dial string on any carrier.

Line 4 will match a user dialing 81011 and a whole bunch of digits (off the screen so no idea how many). But strips the 8 and sends the rest. This is an invalid configuration.

I can continue to pick this apart if you want…

Unrelated to the thread, but the screen caps indicate you’re running an EOL version of FreePBX. It’s long past time to be planning for a move to a supported version.

That set up was what I was using to try and get international calling working, the long distance one posted above is what the rest of the facility works with, and it functions perfectly, without issue.

Actually, no it does not. At least not how you think.

I plan on it once I get everything squared away, I’ve been trying to spearhead upgrading the facilities PCs and what not, a lot of things here need a serious update.

What do your users actually press into their phone?

This is what the rest of the building uses, as far as I can see, we use 81 to dial out, unless it’s just the 8, and the 1 is for the normal US numbers. which it very well might be.

That is NOT what that screenshot shows… You are misreading it.

if you don’t mind me asking, forgive my ignorance on this, but what exactly is it showing?

Answer my question first.

usually 81, but it looks like the 1 is just to dial the numbers inside the U.S. I got it to dial out to the UK just now actually!

With the screenshot shown, if the user dials areacode+number, the Outbound Route will add 81 to the front and pass it to the trunk. The trunk rules could modify the number, as could the Adtran gateway (which seems to be for analog lines, is that what Spectrum is providing?).

We need logs! The phones could be modifying the number (or not accepting all of it) and we don’t know what the PBX or Adtran is really doing.

Please log a test call to 631 791 8378 (The Test Call in New York) and one attempted one to the London number. Paste the log at and post the link here.

Edit: Glad to hear you got it working; I was typing this while your latest post came in, but if you still have any trouble, please post the log.

I thank you for your help on this, your suggestion worked like a charm!

Thank you everyone for your assistance!!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.