Internal Caller ID not correct after upgrading to 2.2.3

Ok previous system was TB 2.0 using freepbx 2.2.1, current system is TB 2.2.3 using freepbx 2.2.3.

At some point in the past a change was made to data going into the sip table such that the callerid keyword has now changed to "device " instead of previously "user name ".

Now I know this was done before version 2.2.1 as that version also did it but using a Aastra 9133i phone system when one person called another internally the users name was displayed along with the extension number. Now since upgrading (happened last Wednesday night) any of those extensions I edited in the last 6 months or so or even one I edited last night now show the callerid name as “device”.

I’ve done a bit of digging. These changes are reflected in the sip_additional.conf file which is re-written every time a change is made to a extension. It re-generates this data from the sip table in the asterisk database. Which is also did in 2.2.1 but somehow in 2.2.1 it still showed the proper name in our phone display (I tested this last night be re-booting to the previous version I have saved as a mirroed drive). But since moving to 2.2.3 2/3 of our company is now displaying as “device” instead of there name.

I’m not sure what was doing that translation in 2.2.1 that made it work correctly, but my quick fix last night was to hand edit the sip table where keyword = “callerid” and data started with “device” and put it to the older format of "user name " as that still works.

Anybody have a solution so I’m not re-editing things every two weeks?

I’ve also seen this since I upgraded to 2.2.3.

I will kill my thread I just started. Count me in too.

For some reason, my sip_additional.conf reflects deivce/xxx instead of the FreePBX Display name field. heres a snip

[email protected]
callerid=device <2208>

In this case, the callerID should be set to FranksHouse but instead its device <2208> Im not sure what is going wrong here. I THINK this happened when I moved the system from one hardware platform to the other. I backed up the existing system using the backup tool in freepbx, and restored all files to the new install. Any help would be appreciated. I wish it was just as easy as editing the sip_additional.conf but there is more to it than that. How much I dont know. I upgraded to the beta to see if that would fix the issue. It did not.

his has been an issue in the past because of different parsers embedded in retrieve_conf. It is resolved (hopefully) going forward in 2.3 where retrieve_conf uses the same included parser as the rest.

this behavior is usually a symptom of your astdb settings getting blow away sometimes (I think there may be a bug in the backup/restore module somewhere). You can confirm by doing a database show AMPUSER/ for the extension in question that is showing up as device in the CID. You would have to trace your steps wrt to why the astdb got blown away but that is most likely your problem.

Im not quite sure how to follow your instructions to resolve this. Do I need to blow away the mySQL table, or is there some other way?

Ok I can execute the database show in asterisk and get a bunch of stuff.

But exactly which table would be having the problem in MYSQL? I have direct access to the TB 2.0/freepbx 2.2.1 system that it was moved from. So I can compair tables directly if I know which table to look at and see if they are different.

Like I said my earlier version which was alway a upgrade from previous version worked. Just the sip_additional was showing the callerid=device for any touched extensions since Jan 14th (When I upgraded from TB 1.2.3 to TB 2.0). They worked properly just noticed the issue in the sip_additional but it all works fine. When I did a backup and restore to move to the new build it all started to fail. So if you can point me to some table to review I can try and locate where it failed and help document the problem and fix my issue in the same movement.

In correct and functioning system what should the data field data look like for this query on the sip table?

SELECT * FROM sip WHERE keyword = ‘callerid’

All my good one (That’s my opinion) have 'user name ’ the one’s I’m having issues with are the records that have 'device ’

the mysql table is correct. (it should say device). The easiest way to correct it is to go to each extension and resubmit it with no editing.

Thank you very much! To be clear, I went into FreePBX admin, and selected extensions, then i clicked on each extension, and hit the submit button at the bottom of the page. after I did each and every extension, I hit apply. Everything is the way its supposed to be now

Not a lot of fun doing it to the number of extension I have, but it solved the problem.

Thank you.

Hmmm… The Caller ID seems to change depending on what was called:

Look at these 2 CDR entries:

[list] 2007-08-02 20:00:20 SIP/128-09… 128 “Pocket PC” <128> *65 ANSWERED 00:03
2007-08-02 19:52:01 SIP/128-09… 128 “device” <128> *60 ANSWERED 00:08[/list:u]

I changed nothing in between these calls.

Not sure if I missed the point of the original post but surely this inconsistency is a cause for irritation at least?


When I went into the GUI and applied a non-exsistent change to each SIP extention, then applied them, it fixed the internal SIP CID problem on xten to xten calling.

I did notice today that on an Intercom (*80 prefix) the CID is still showing up as “device” and Xten#.

So I have have this issue - I’m suspecting it is an Asterisk issue? Any thoughts?

[code:1]3. 2007-08-08 13:21:07 SIP/101-0a… 101 “device” <101> musiconhold ANSWERED 00:42
4. 2007-08-08 13:18:04 SIP/101-0a… 101 “TMQHP 7940” <101> 16 ANSWERED 00:16
5. 2007-08-08 13:17:44 SIP/101-0a… 101 “TMQHP 7940” <101> 16 ANSWERED 00:07[/code:1]

Here you see it records correctly when I dial 16 (a queue) but records ‘device’ when I route to app-blackhole/musiconhold.


I am not sure if this is in the same line but I noticed that of late (last 3 weeks) that my caller id is not correct. What I have decerned is that it is taking names that are defined in extensions and applying them to the incoming calls. This is happening with both sip & zap calls. I am currently using freepbx 2.3 with asterisk 1.4.8 but I am stumped as to why this is happening. Also, after having used freepbx for some time now, I began to question, in the caller id section, when it asks for database name, what is the correct response? Is there a default? If you happen to mistype something does the script create the tables or database?

Excuse my ignorance on this. Inquiring minds want to know (at least I would like to know).


for those inquiring minds that want to know, take a look at FreePBX Devices and Users Under the Hood.

Philippe Lindheimer - FreePBX Project Lead
http// - IRC #freepbx