Internal call pickup (*8) failing

Hi All

I have an issue with call pickup (*8) on Asterisk. The extensions are in the correct Pickup and Call groups as it works fine on external calls but drops internal calls after about 6 seconds. Before the call is dropped, there are no problems with audio. I initially thought it may be a codec issue, but looking at a packet capture all phones are using g.711. The phones are Cisco 7911’s, 7941’sand 7942’s.

Here is the capture right where the call disconnects

[2015-07-06 13:21:08] WARNING[6887]: chan_sip.c:4024 retrans_pkt: Retransmission timeout reached on transmission [email protected] for seqno 102 (Critical Response) – See https:// wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 6399ms with no response
[2015-07-06 13:21:08] WARNING[6887]: chan_sip.c:4053 retrans_pkt: Hanging up call [email protected] - no reply to our critical packet (see https:// wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions).
Scheduling destruction of SIP dialog ‘[email protected]’ in 6400 ms (Method: INVITE)
set_destination: Parsing sip:[email protected]:49729;transport=tcp for address/port to send to
set_destination: set destination to xxx.xxx.xxx.101:49729
Reliably Transmitting (no NAT) to xxx.xxx.xxx.101:49729:
BYE sip:[email protected]:49729;transport=tcp SIP/2.0
Via: SIP/2.0/TCP xxx.xxx.xxx.25:5060;branch=z9hG4bK7010a383
Max-Forwards: 70
From: sip:*[email protected];tag=as57f11c7b
To: “Test1” sip:[email protected];tag=001819280fa31b9f156f65b0-62446540
Call-ID: [email protected]
CSeq: 102 BYE
User-Agent: Custom
Proxy-Authorization: Digest username=“254”, realm=“asterisk”, algorithm=MD5, uri=“sip:xxx.xxx.xxx.25”, nonce=“2f7f983f”, response="60601ae4daf25619917613a120dabaf0"
X-Asterisk-HangupCause: Normal Clearing
X-Asterisk-HangupCauseCode: 16
Content-Length: 0

We have several Call groups set up and it happens on all of them. It also happen when you dial **ext number.

Can Reinvite is set to No on the extensions and SIP canreinvite (directmadia) in advanced settings is set to no. I also tried changing it to yes and nonat with no change in the outcome.

We are using a FreePBX Distro SHMZ release 6.5 (Final) with FreePBX 12.0.70 with Asterisk 11.18.0.

I have changed the phone firmware from 8-5-2SR1 to 9-3-1SR4-1S with no change.

Thanks

David

I have sine built a PBX in a flash (PIAF) system to similar specs and there is no problem using *8 for internal and external calls.

I restored a backup from the FreePBX server to the PIAF server and the *8 issue was back. Somewhere in the config there is a problem. I compared all of the SIP configuration files and the extension files between the 2 servers, made them almost identical and still had the problem. I don’t know where to look next

I am really trying to avoid replacing my current server.

Thanks

David

That stuff will likely be in the sqlite3 asteriskdb database.

@WMP1 were you ever able to identify a fix for this with FreePBX? I have the same issue after converting from a CUCM environment to Asterisk/FreePBX.

Thanks,
Blake

It turned out to be a firmware problem. I updates all of the Cisco phones to SIP 9.4.2SR1 and it now works fine.

Thanks David. I attempted to get 9.4.2SR1 working but could never get the phones to register properly so I stayed with 8.5.4.

Did you also run into any issues with 9.4.2 and if so can you share your fixes and/or config files?

Thanks,
Blake

Hi Blake

I had a few problems as well. Start here http://www.voip-info.org/wiki/view/Asterisk+phone+cisco+79x1+xml+configuration+files+for+SIP follow te detaial under version 9.2 as the transport is TCP.

For FreePBX I also had to add under sip_custom.conf

for each extension. Change 400 and 401 to your extension numbers.

There is a bug in FreePBX (although they dont seem to think so) that does not allow you to set tcp even though you set it on the extension

Hope this helps
David

The manual conf file changes you show correspond exactly to setting chan_sip extension 400 Transport (on the advanced tab) to “All UDP Primary”. I’m not seeing a bug.

Thanks David and Lorne,

I will setup a couple of phones in my lab and attempt to get 9.4.2 working on them using TCP. Hopefully this will fix my issue and I can easily apply it to the over 800 handsets I have deployed!

Blake

Still no luck in getting one of my 7942’s to register. I have attempted many different configurations variants based on the link provided as well as many Cisco SIP 9.x software loads. Most with the same result. The phone is showing not registered and a fast busy is received on attempted outbound calls.

However I did come closest in getting the phone to work using version 9.2.1. With this version I was able to make outbound calls but not receive any inbound to the phone, it still showed as unregistered on the PBX and phone itself.

@WMP1 Would you mind sharing one your working SEPMAC.cfg files, minus the passwords of course, so that I can so a stare and compare to try to identify any differences?

Also, do you know of a way to verify that an extension is configured for and responding to TCP packets in FreePBX V12? When I use TCPDUMP I am seeing some TCP traffic with 9.x but I cannot verify if the 7942 and PBX are communicating via TCP and not UDP any longer.

Thanks,
Blake

Hi Blake

Below is a copy of a SEPMAC file.

Im trying to think of the issue I’ve had.

I’m using ChanSIP not PJSIP
Make sure the Phone label is less than 12 characters and avoid spaces.
Cisco have a program called “TranslatorX” that is god for looking at your packet captures.

Hope this helps

<device>
  <deviceProtocol>SIP</deviceProtocol>

  <sshUserId>admin</sshUserId>
  <sshPassword>cisco</sshPassword>

  <devicePool>
		<dateTimeSetting> 
			<dateTemplate>D/M/Y</dateTemplate> 
			<timeZone>Cen. Australia Standard/Daylight Time</timeZone> 
			<ntps> 
				<ntp>
					<name>NTP SERVER IP</name> 
					<ntpMode>Unicast</ntpMode> 
				</ntp>
			</ntps>
		</dateTimeSetting> 

     <callManagerGroup>
        <members>
           <member priority="0">
              <callManager>
                 <ports>
                    <ethernetPhonePort>2000</ethernetPhonePort>
                    <sipPort>5060</sipPort>
                    <securedSipPort>5061</securedSipPort>
                 </ports>
                 <processNodeName>FREEPBX IP</processNodeName>
              </callManager>
           </member>
        </members>
     </callManagerGroup>

  </devicePool>

  <commonProfile>
     <phonePassword>cisco</phonePassword>
     <backgroundImageAccess>true</backgroundImageAccess>
     <callLogBlfEnabled>2</callLogBlfEnabled>
  </commonProfile>

  <loadInformation>SIP42.9-4-2SR1-1S</loadInformation>

   <vendorConfig>
     <disableSpeaker>false</disableSpeaker>
     <disableSpeakerAndHeadset>false</disableSpeakerAndHeadset>
     <pcPort>0</pcPort>
     <settingsAccess>1</settingsAccess>
     <garp>0</garp>
     <voiceVlanAccess>0</voiceVlanAccess>
     <videoCapability>0</videoCapability>
     <autoSelectLineEnable>0</autoSelectLineEnable>

     <webAccess>1</webAccess>
     <spanToPCPort>1</spanToPCPort>
     <loggingDisplay>1</loggingDisplay>
     <loadServer></loadServer>

  </vendorConfig>

<userLocale> 
<name>English_Australia</name> 
<uid>1</uid> 
<langCode>en_US</langCode> 
<version>1.0.0.0-1</version> 
<winCharSet>iso-8859-1</winCharSet> 
</userLocale> 

  <networkLocale>English_Australia</networkLocale> 

	<networkLocaleInfo> 
		<name>Australia</name> 
		<uid>64</uid> 
		<version>1.0.0.0-1</version> 
	</networkLocaleInfo> 

  <deviceSecurityMode>1</deviceSecurityMode>
  

  <transportLayerProtocol>4</transportLayerProtocol>

  <capfAuthMode>0</capfAuthMode>
  <capfList>
     <capf>
        <phonePort>3804</phonePort>
     </capf>
  </capfList>

  <certHash></certHash>
  <encrConfig>false</encrConfig>

<sipProfile>
     <sipProxies>
        <registerWithProxy>true</registerWithProxy>
     </sipProxies>

     <sipCallFeatures>
        <cnfJoinEnabled>true</cnfJoinEnabled>
        <rfc2543Hold>false</rfc2543Hold>
        <callHoldRingback>2</callHoldRingback>
        <localCfwdEnable>true</localCfwdEnable>
        <semiAttendedTransfer>true</semiAttendedTransfer>
        <anonymousCallBlock>2</anonymousCallBlock>
        <callerIdBlocking>2</callerIdBlocking>
        <dndControl>0</dndControl>
        <remoteCcEnable>true</remoteCcEnable>
     </sipCallFeatures>

     <sipStack>
        <sipInviteRetx>6</sipInviteRetx>
        <sipRetx>10</sipRetx>
        <timerInviteExpires>180</timerInviteExpires>
        <timerRegisterExpires>3600</timerRegisterExpires>
        <timerRegisterDelta>5</timerRegisterDelta>
        <timerKeepAliveExpires>120</timerKeepAliveExpires>
        <timerSubscribeExpires>120</timerSubscribeExpires>
        <timerSubscribeDelta>5</timerSubscribeDelta>
        <timerT1>500</timerT1>
        <timerT2>4000</timerT2>
        <maxRedirects>70</maxRedirects>
        <remotePartyID>false</remotePartyID>
        <userInfo>None</userInfo>
     </sipStack>

     <autoAnswerTimer>1</autoAnswerTimer>
     <autoAnswerAltBehavior>false</autoAnswerAltBehavior>
     <autoAnswerOverride>true</autoAnswerOverride>
     <transferOnhookEnabled>false</transferOnhookEnabled>
     <enableVad>false</enableVad>
     <preferredCodec>none</preferredCodec>
     <dtmfAvtPayload>101</dtmfAvtPayload>
     <dtmfDbLevel>3</dtmfDbLevel>
     <dtmfOutofBand>avt</dtmfOutofBand>
     <alwaysUsePrimeLine>false</alwaysUsePrimeLine>
     <alwaysUsePrimeLineVoiceMail>false</alwaysUsePrimeLineVoiceMail>
     <kpml>3</kpml>
     <natEnabled></natEnabled>
     <natAddress></natAddress>

     <stutterMsgWaiting>0</stutterMsgWaiting>

     <callStats>false</callStats>
     <silentPeriodBetweenCallWaitingBursts>10</silentPeriodBetweenCallWaitingBursts>
     <disableLocalSpeedDialConfig>false</disableLocalSpeedDialConfig>


     <startMediaPort>16384</startMediaPort>
     <stopMediaPort>32766</stopMediaPort>

     <voipControlPort>5060</voipControlPort>
     <dscpForAudio>184</dscpForAudio>
     <ringSettingBusyStationPolicy>0</ringSettingBusyStationPolicy>
     <dialTemplate>dialplan.xml</dialTemplate>

     <phoneLabel>Spare</phoneLabel>

     <sipLines>
        <line button="1">
           <featureID>9</featureID>
           <featureLabel>EXT NUMBER</featureLabel>		   		
		<name>EXT NUMBER</name>
		<displayName>USER NAME</displayName>	   
           <proxy>USECALLMANAGER</proxy>
           <port>5060</port>
           <autoAnswer>
              <autoAnswerEnabled>2</autoAnswerEnabled>
           </autoAnswer>
           <callWaiting>3</callWaiting>

           <authName>EXT NUMBER</authName>
           <authPassword>EXT PASSWORD</authPassword>

           <sharedLine>false</sharedLine>
           <messageWaitingLampPolicy>1</messageWaitingLampPolicy>
           <messagesNumber>*97</messagesNumber>
           <ringSettingIdle>4</ringSettingIdle>
           <ringSettingActive>5</ringSettingActive>

           <forwardCallInfoDisplay>
              <callerName>true</callerName>
              <callerNumber>false</callerNumber>
              <redirectedNumber>false</redirectedNumber>
              <dialedNumber>true</dialedNumber>
           </forwardCallInfoDisplay>
        </line>

        

     </sipLines>
  </sipProfile>

  <servicesURL>http://cisco.internect.net</servicesURL>
</device>

David

Still no luck. When I take your SEPMAC and edit it for my PBX the phone sticks at “Registering”. When I return it to my config I get past the “Registering” and see the bottom soft buttons however the phone line icon still has an X on it and in/out calls will not work.

Which version of FreePBX are you using and did you make any other changes at an extension or system level to get the phone working with TCP?

I am leaning towards this being an issue on the PBX side and not with the phone as I have tried almost everyone of the 9.x versions now with the same results. I do have working phones using the 8.x version.

Thanks,
Blake

Hi Blake

Im using FreePBX 13.0.190.19

Set NAT to no on both the sip settings and the extension.
I have also had issues with the password. Although Im sure I typed it correctly, when I copied and pasted it, it worked.

sip_custom.conf
sendrpid=yes
trustrpid=no

udpbindaddr=0.0.0.0
tcpenable=yes
tcpbindaddr=0.0.0.0
callcounter=yes
transport=tcp, udp

progressinband=yes

If you want, you can you send me the tcpdump file and I wiull have a quick look.

Regards

David

Thanks for the offer David. Do you have a preferred method in getting you the PCAP? I don’t see a way to attach to this message. When I look at the PCAP I am seeing a SIP 603 Declined being return by the PBX but only a REFER being sent by the Cisco 7942. We are also running this in a HA pair in case it matters.

FPBX-12.0.76.4(11.21.2)
etc/asterisk/sip_additional.conf
[9998]
deny=0.0.0.0/0.0.0.0
secret=11aa22bb
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
trustrpid=no
mediaencryption=no
sendrpid=yes
type=friend
nat=no
port=5060
qualify=yes
qualifyfreq=60
transport=tcp,udp,tls
avpf=no
force_avp=no
icesupport=no
encryption=no
callgroup=
pickupgroup=
dial=SIP/9998
[email protected]
permit=0.0.0.0/0.0.0.0
callerid=TestBLF1 <9998>
callcounter=yes
faxdetect=no
cc_monitor_policy=generic

Here is a copy of the latest SEPMAC that I an using. I can call out but not in and the phone does not show as registered either on the phone display or in FreePBX.

<?xml version="1.0" encoding="utf-8"?>
<device>
 <deviceProtocol>SIP</deviceProtocol>
 <transferonhookenabled>true</transferonhookenabled>
 <stopmediaport>16399</stopmediaport>
 <voipcontrolport>5061</voipcontrolport>
 <rfc2543hold>true</rfc2543hold>
 <calleridblocking>0</calleridblocking>
 <remotepartyid>false</remotepartyid>
 <versionStamp>1143565489-a3cbf294-7526-4c29-8791-c4fce4ce4c37</versionStamp>
 <deviceSecurityMode>1</deviceSecurityMode>
 <dscpForSCCPPhoneConfig>96</dscpForSCCPPhoneConfig>
 <dscpForSCCPPhoneServices>0</dscpForSCCPPhoneServices>
 <dscpForCm2Dvce>96</dscpForCm2Dvce>
 <capfAuthMode>0</capfAuthMode>
 <encrConfig>false</encrConfig>
 <loadInformation>SIP42.9-4-2SR1-1S</loadInformation>
 <sshUserId>admin</sshUserId>
 <sshPassword>cisco</sshPassword>
 <transportLayerProtocol>2</transportLayerProtocol>
  <devicePool>
    <dateTimeSetting>
      <dateTemplate>M/D/YA</dateTemplate>
      <timeZone>Pacific Standard/Daylight Time</timeZone>
      <ntps>
        <ntp>
          <name>172.17.10.3</name>
          <ntpMode>Unicast</ntpMode>
        </ntp>
      </ntps>
    </dateTimeSetting>
    <callManagerGroup>
      <members>
        <member>
          <callManager>
            <processNodeName>10.110.0.10</processNodeName>
            <ports>
              <sipPort>5060</sipPort>
              <securedSipPort>5061</securedSipPort>
            </ports>
          </callManager>
        </member>
      </members>
    </callManagerGroup>
  </devicePool>
  <sipProfile>
    <autoAnswerTimer>1</autoAnswerTimer>
    <autoAnswerAltBehavior>false</autoAnswerAltBehavior>
    <autoAnswerOverride>true</autoAnswerOverride>
    <transferOnhookEnabled>false</transferOnhookEnabled>
    <enableVad>false</enableVad>
    <dtmfAvtPayload>101</dtmfAvtPayload>
    <dtmfDbLevel>3</dtmfDbLevel>
    <dtmfOutofBand>avt</dtmfOutofBand>
    <alwaysUsePrimeLine>false</alwaysUsePrimeLine>
    <alwaysUsePrimeLineVoiceMail>false</alwaysUsePrimeLineVoiceMail>
    <kpml>3</kpml>
    <phoneLabel>TestBLF1</phoneLabel>
    <stutterMsgWaiting>1</stutterMsgWaiting>
    <callStats>false</callStats>
    <offhookToFirstDigitTimer>15000</offhookToFirstDigitTimer>
    <silentPeriodBetweenCallWaitingBursts>10</silentPeriodBetweenCallWaitingBursts>
    <disableLocalSpeedDialConfig>false</disableLocalSpeedDialConfig>
    <startMediaPort>16384</startMediaPort>
    <stopMediaPort>32766</stopMediaPort>
    <voipControlPort>5060</voipControlPort>
    <dscpForAudio>184</dscpForAudio>
    <ringSettingBusyStationPolicy>0</ringSettingBusyStationPolicy>
    <softKeyFile></softKeyFile>
    <dialTemplate>dialplan.xml</dialTemplate>
    <sipProxies>
      <outboundProxy></outboundProxy>
      <outboundProxyPort></outboundProxyPort>
      <emergencyProxyPort></emergencyProxyPort>
      <emergencyProxy></emergencyProxy>
      <backupProxyPort></backupProxyPort>
      <backupProxy></backupProxy>
      <registerWithProxy></registerWithProxy>
    </sipProxies>
    <sipCallFeatures>
      <cnfJoinEnabled>true</cnfJoinEnabled>
      <callForwardURI>x-cisco-serviceuri-cfwdall</callForwardURI>
      <callPickupURI>x-cisco-serviceuri-pickup</callPickupURI>
      <callPickupListURI>x-cisco-serviceuri-opickup</callPickupListURI>
      <callPickupGroupURI>x-cisco-serviceuri-gpickup</callPickupGroupURI>
      <meetMeServiceURI>x-cisco-serviceuri-meetme</meetMeServiceURI>
      <abbreviatedDialURI>x-cisco-serviceuri-abbrdial</abbreviatedDialURI>
      <rfc2543Hold>false</rfc2543Hold>
      <callHoldRingback>2</callHoldRingback>
      <localCfwdEnable>true</localCfwdEnable>
      <semiAttendedTransfer>true</semiAttendedTransfer>
      <anonymousCallBlock>2</anonymousCallBlock>
      <callerIdBlocking>2</callerIdBlocking>
      <dndControl>0</dndControl>
      <remoteCcEnable>true</remoteCcEnable>
    </sipCallFeatures>
    <sipStack>
      <sipInviteRetx>6</sipInviteRetx>
      <sipRetx>10</sipRetx>
      <timerInviteExpires>180</timerInviteExpires>
      <timerRegisterDelta>5</timerRegisterDelta>
      <timerKeepAliveExpires>120</timerKeepAliveExpires>
      <timerSubscribeExpires>120</timerSubscribeExpires>
      <timerSubscribeDelta>5</timerSubscribeDelta>
      <timerT1>500</timerT1>
      <timerT2>4000</timerT2>
      <maxRedirects>70</maxRedirects>
      <remotePartyID>true</remotePartyID>
      <userInfo>None</userInfo>
      <timerRegisterExpires>3600</timerRegisterExpires>
    </sipStack>
    <sipLines>
      <line button="1">
        <featureID>9</featureID>
        <featureLabel>9998</featureLabel>
        <port>5060</port>
        <name>9998</name>
        <displayName>9998</displayName>
        <callWaiting>3</callWaiting>
        <authName>9998</authName>
        <authPassword>11aa22bb</authPassword>
        <sharedLine>false</sharedLine>
        <messagesNumber>*97</messagesNumber>
        <ringSettingIdle>4</ringSettingIdle>
        <ringSettingActive>5</ringSettingActive>
        <contact>9998</contact>
        <speedDialNumber></speedDialNumber>
        <featureOptionMask></featureOptionMask>
        <messageWaitingLampPolicy>1</messageWaitingLampPolicy>
        <serviceURI></serviceURI>
        <proxy>USECALLMANAGER</proxy>
        <autoAnswer>
          <autoAnswerEnabled>2</autoAnswerEnabled>
        </autoAnswer>
        <forwardCallInfoDisplay>
        </forwardCallInfoDisplay>
      </line>
      <line button="2">
        <callWaiting>3</callWaiting>
        <sharedLine>false</sharedLine>
        <messageWaitingLampPolicy>3</messageWaitingLampPolicy>
        <messagesNumber>*97</messagesNumber>
        <ringSettingIdle>4</ringSettingIdle>
        <ringSettingActive>5</ringSettingActive>
        <featureID>2</featureID>
        <featureLabel></featureLabel>
        <proxy></proxy>
        <port></port>
        <name></name>
        <displayName></displayName>
        <authName></authName>
        <authPassword></authPassword>
        <contact></contact>
        <serviceURI></serviceURI>
        <speedDialNumber></speedDialNumber>
        <featureOptionMask>1</featureOptionMask>
        <autoAnswer>
          <autoAnswerEnabled>2</autoAnswerEnabled>
        </autoAnswer>
        <forwardCallInfoDisplay>
        </forwardCallInfoDisplay>
      </line>
    </sipLines>
  </sipProfile>
  <commonProfile>
    <phonePassword></phonePassword>
    <backgroundImageAccess>true</backgroundImageAccess>
    <callLogBlfEnabled>2</callLogBlfEnabled>
  </commonProfile>
  <vendorConfig>
    <disableSpeaker>false</disableSpeaker>
    <disableSpeakerAndHeadset>false</disableSpeakerAndHeadset>
    <pcPort>0</pcPort>
    <settingsAccess>1</settingsAccess>
    <garp>0</garp>
    <voiceVlanAccess>0</voiceVlanAccess>
    <autoSelectLineEnable>0</autoSelectLineEnable>
    <webAccess>0</webAccess>
    <daysDisplayNotActive></daysDisplayNotActive>
    <displayOnTime>00:00</displayOnTime>
    <displayOnDuration>23:59</displayOnDuration>
    <displayIdleTimeout>00:10</displayIdleTimeout>
    <spanToPCPort>1</spanToPCPort>
    <videoCapability>0</videoCapability>
    <ehookEnable>1</ehookEnable>
    <sshPort>22</sshPort>
    <sshAccess>0</sshAccess>
  </vendorConfig>
  <userLocale>
    <uid></uid>
    <name></name>
    <langCode></langCode>
    <version></version>
    <winCharSet></winCharSet>
  </userLocale>
  <networkLocaleInfo>
    <uid></uid>
    <version>5.0(2)</version>
    <name>US</name>
  </networkLocaleInfo>
  <capfList>
    <capf>
      <phonePort>3804</phonePort>
    </capf>
  </capfList>
</device>

Thanks for the assist!
Blakejustsip.pcapng.tgz (3.0 KB)

What a way to spend a beautiful Saturday… Not! But I did make some progress today. Thank you again @WMP1 for offering to assist, it is greatly appreciated.

Today’s Update:

  1. TCP is configured and working
    netstat -tlpn | grep 5060
    tcp 0 0 0.0.0.0:5060 0.0.0.0:* LISTEN 18024/asterisk

  2. Test phone, ext 9998, is registered to PBX via TCP
    asterisk -rx "sip show tcp"
    Address Transport Type
    10.110.0.100:51135 TCP Server

9998/9998 10.110.0.100 D No No A 51135 OK (22 ms)

Problems I am still seeing:

  1. “Weirdness” with calling between TCP and UDP phones (SIP BYE not being seen, transfer not working)
  2. Ext 9998 is registering on high, random port numbers and not on 5060. Cannot see why in config?
  3. Noticing multiple, up to 48, INVITES showing up in Chan_Sip Channels for the TCP configured phone. All with the same call ID.
    10.110.0.100 9998 ecc88210-5fc500 (nothing) No Rx: INVITE 9998

Questions:

  1. Are all of your extensions using TCP?
  2. Are your TCP extensions registered on port 5060?
  3. If so did you change anything in the SEPMAC or PBX side to force this setting?
  4. Do you also show multiple invites in the Chan_Sip for your TCP extensions?

Hoping you will have some insight and help direct me towards a next step… Off to enjoy whats left of the day!

Thanks,
Blake

Hello @WMP1. Was wondering if you will have a chance to see if you are also seeing some of the same TCP options that I am seeing?

Thanks,
Blake