Intermittent One-Way Audio -- No NAT


Running FreePBX with Asterisk 13.19.1 and later upgraded to Asterisk 13.21.1

I am having intermittent one-way audio problems. There is no NAT involved and I run VPN’s from each site back to the datacenter with the PBX. I have done packet captures at the FreePBX machine and see the SIP/SDP ports the RTP audio should be sent to however the PBX doesn’t send the RTP resulting in one-way audio.

I have attached a capture showing a user at one site calling the ring group which rings at the other site. The two calls in the capture resulted in one-way audio and the 3rd call (not part of the capture) worked.

At this point I assume the issue is somewhere inside the PBX but I don’t know what other troubleshooting steps I should take or what to look for in the logs. The issue doesn’t happen very often and
haven’t found any patterns. I get a complaint about once or twice a day but suspect many people don’t complain about it.

Filtered_203-240.tgz (226.8 KB)

Are you sure you have your Asterisk SIP Settings set-up correctly? You’ll need to list all networks accessible via VPN as Local Networks.

I don’t see how you can do a VPN without an internal IP and NAT.

1 Like

Hi I confirm all my site subnets are defined as local networks and the vast majority of calls are working correctly.

The calls in the capture are from one site to the other and as mentioned previously there is no NAT traversal involved.

We are now running FreePBX with Asterisk 13.22.0

We are still seeing these intermittent one-way audio problems. I have noticed it appears to affect calls to ring groups. The issue appears to be with Asterisk because the log files clearly show RTP missing on one leg of the call. The packet captures mirror this condition of no RTP leaving the PBX (the original one in the first post displays this clearly).

I have included an Asterisk log with pretty much maximum verbose and debuggging. This example is call from ext 209 calling ring group 270 (ext 271, 272, 279) and 271 answers the call but does not receive audio from 209.

Full_asterisk_debuglog.tgz (71.4 KB)

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.