Interface in firewall automatically switches back to Trusted

I have a new installation of FreePBX, Stable 10.13.66 installed directly from the ISO a few days ago. I’m having an issue with the firewall in which I change the eth0 interface to external, but after a reboot it sets itself back to trusted and the dashboard reports the following error:

Interface eth0 is not in the correct zone. This can be caused by manual alterations of iptables, or, an unexpected error. Please restart the firewall service.

I’ve restarted the firewall service several times to not affect. This is what I’ve tried so far:

  • Change interface from trusted to external. as soon as I hit save, I lose web access.
  • run “fwconsole firewall stop” in the cli
  • run “fwconsole firewall start” in the cli
  • back in the web interface, the interface shows up as external and the notice on the dashboard is gone.

However, after a reboot, the interface goes back to trusted and the error returns.

Any suggestions?

Check this out, it may help…

Btw, loosing web access if your remoting in is normal for http, default settings for http doesn’t include external, BUT default settings for https work for external. so add an “s” and you should be back in.