Intercom usage


#1

Hi I’m new to FreePBX and only have a little asterisk experience so perhaps someone could answer a question about the paging application. This is a new installation and I am evaluating several phones for transitioning my company from a legacy pbx.

I am being told that by dialing *80 I will be asked for the extension I would like to establish an intercom session with. Similar to the voicemail application (by dialing *98). This is not the case on my installation (Asterisk 1.4, FreePBX core 2.5.1.1 and intercom 2.5.0.6). I get no response to dialing *80. A pcap shows:

Request: INVITE sip:*80@192.168.xxx.xxx, with session description
Status: 407 Proxy Authentication Required
Request: ACK sip:*80@192.168.xxx.xxx
Request: INVITE sip:*80@192.168.xxx.xxx, with session description
Status: 484 Address Incomplete
Request: ACK sip:*80@192.168.xxx.xxx

Looking through extensions_additional.conf I see this: *98,n,Noop(app-dialvm: Asking for mailbox) *98,n,Read(MAILBOX,vm-login,,,3,2) extensions_additional.conf:exten => *98,n(check),Noop(app-dialvm: Got Mailbox ${MAILBOX}) but nothing like this for the intercom application.

So is this not a feature of the FreePBX intercom application? Is this an Asterisk feature that has been implemented locally by the organization telling me this?

Enlighten me please.

Additionally - is there a way to make this work without doing a feature request for the intercom module? If I add a Read() line FreePBX will just overwrite it, yes?


All page muting active calls
#2

In that you are used to working with asterisk and not FreePBX. A couple of pointers for you. Many of the files like extensions.conf and extensions_additional.conf are “owned” by FreePBX so don’t go editing them. You can find more info by following the link posted at the top of each of those files.

Next make sure that you have the the paging and intercom module installed and enabled via the module admin. Next make sure that the paging feature code is enabled via the feature codes page otherwise it will not work.

Past that it should them be ready to work. The last thing that needs to happen is that the phones need to be configured for auto answer which is a unique process for each manufactures phone. (i.e. the process for Aastra is not the same for Polycom).

If you are looking to do group paging you’ll need to assign groups of phones to groups but it is strieght forward at that point.


#3

Thank you for your quick reply but if you review my original message you will see I mention the version of the intercom module I have installed.

FreePBX has setup intercom/paging and it is all working properly. Dialing *80123 starts an intercom session with extension 123.

My question actually relates to setting up a softkey on a phone to provide single button intercom functionality. The phone manufacturer says their softkey intercom function is working properly with asterisk. In other words, they say that dialing the intercom feature code without an extension will cause Asterisk to ask for the extension you wish to intercom.

This does not work on my FreePBX+intercom-module installation. My question is why? Is this ask-for-extension feature something that is standard or does the phone vendor have a custom asterisk intercom setup which enables this to work? Do any other Asterisk management systems provide this feature and if so maybe someone could share the code to do this?

After studying the configuration files more I spotted the link to the method provided for altering FreePBX features. Unfortunately I do not have the knowledge required to implement this intercom feature.


#4

Sorry I was in boring meeting reading and attempted to reply while I had divided attentions… Yes I know I should not have done that.

The process that *98 uses to get the extension is built into the voicemailmain() routine (which is a C compiled module for asterisk) and not a generalized single line call to read dtmf from a phone.


#5

I have Cisco SPA Phones.
Specifically SPA525G2 and SPA504G.
Here is the comment/question I have to this thread.

I have intercom enabled every option on each of these SPA phones enabled as explained above (word to those whom are new to these, paging and intercom work by default) The problem I have is that when I intercom from my SPA525G2 to a SPA504 phone this process works!

When I go the opposite direction (504-525) I cannot it gives me the same error as stated above “484 Address Incomplete”

Now when I try to just dial *80xxx (xxx = extension number) on my 525 it will not intercom the person, rather give me a TONE prompting me to enter digits, if I press the extension and dial. This intercoms…

Going to the 504 this does not happen, I tried *80 Dial and get “484 Address Incomplete” or I try *80xxx Dial “484 Address Incomplete”

Anyone knows what this is about?


#6

The dial plan has to be different on the 504’s…Look carefully


#7

I’m having the same issue …can intercom from a 525 to a 504, but can’t initiate intercom from the 504…the settings seem to be exactly the same on both phones.

Did you find a solution?

Thanks in advance…


#8


#9

I’m doing this for the fellow who posted the xkcd comic… I love xkcd

The 504 by default will reject *80123 because the dial plan for the extension does not allow it. I use the following dial plan to enable intercom and directed call pickup **123 I use directed call pickup since my 504 has a SPA500s attendant console connected.

Dial plan:

(**xxx|*xxxxx|[3469]11|0|00|[2-9]xxxxxx|1xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.)

For my clients I use SPA500s attendant console for single button (direct to a phone) intercom buttons.
To make a direct intercom button on a SPA500s attendant console go to the attendant console tab on your SPA phone and input:

fnc=sd;ext=*80123@$PROXY

where 123 is the extension you wish to intercom.

As for the first post about being able to press *80 and have a lady’s voice say “type an extension to intercom followed by the # key.” I have no solution to this. I have seen other systems where this function this way with 504s but this feature does not seem to be available.

One work around for this issue may be to create an IVR. I will have to test this and see if it will work with intercom.


#10

It appears through the use of an extension, IVR and paging groups you could have your own custom recording play then have a user press a key (or an extension number whatever it’s your ivr) and intercom to an extension. This solution will work ok for a small office that does not change out users frequently as it’s a bit custom.

  1. Create a system recording. Say something like: " Intercom : press 1 for Candy, Press 2 for Autumn, Press 3 for Jasmine, Press 4 for Trinity. "

  2. Create page groups one for each user. For example on my network I start with 201, 202, 203, 204 so just to keep things simple in my head I created individual page groups starting at 601, 602, 603, 604 for each person. Be sure to check duplex so it will be two way (intercom).

  3. Create a IVR name it intercom or something. For Announcement set your recording you just made. At the bottom for Ext digits pressed put in the digits you listed off in your recording. Then to the right drop down == Choose from == and select paging and intercom then to the right of that select the right person. Repeat until everyone is in there then submit.

  4. Create a new extension. For device put generic sip device. Assign it whatever extension number you would like (you will use it later when programming your line key on your phone {making your intercom button}) in this case I used 600. At the bottom of this extensions settings under optional destination for No answer, Busy and not reachable choose IVR and to the right of that intercom. Submit and apply settings.

  5. Now try calling 600. Your intercom list should play then you can press whatever key for whatever intercom.

I know it’s not the ideal solution (having *80 actually ask you for a extension) but in the mean time it’s better than nothing I suppose.

If anyone uses this advice then thank the dude who posted the xkcd comic above as it inspired me :wink:


(Mark) #11

Thanks “dude who posted the xkcd comic” … the last solution is actually a smart workaround …
And the comic is oh so true …


(Mikes) #12

I’m testing my new office system thru ringroost and was able to setup my Cisco SPA525G2 phones to call in and out , but cant initiate intercom/ paging and presence options. I’m new to VOIP and not sure if those options part of virtual pbx setup of I can change settings on my phone and activate it. I changed all my setting per Cisco admin guide:

To enable paging, navigate to Admin Login > advanced > Voice > Phone. Under
Supplementary Services in the Paging Serv list, choose yes to enable.
To configure a phone to automatically accept pages, navigate to Admin Login >
advanced > Voice > User. Under Supplementary Services in the Auto Answer
Page list, choose yes to enable.

but i cant initiate any intercom calls anyway.

And with Presence option - I’m not even sure where to start :slight_smile:

Thx for the help
Mike


(TaylorHawkes) #13

Hey Mikes,
Yea Intercom is going to depend on your virtual PBX provider (and your phone’s ability). RingRoost implements it by default by dialing “*07” then the extension you want to auto answer (intercom).

See: ringroost.com/vertical-service-codes.php

Note, that most phones support the ability to enable “Auto Answer”. On some phones you will need to enable that setting. Unfortunately I’m not sure about Cisco SPA525G2, they have “Auto Answer” for paging (the setting you changed), which may work - I would give it a try.

See this tutorial on setting up intercom on RingRoost here:
ringroost.com/blog/intercom-functionality-with-ringroost/