Intercom to Digium D40


(Barry D. Hassler - HCST) #1

Hi, I’m having difficulty intercoming a D40 (and possibly other Digium) phones. The system is successfully intercoming to Sangoma Phones, but the Digium phones never answer the intercom call.

In the asterisk log file, and SIP capture, all appears to be correct, but the phone never picks up (abbreviated log entries follow):

[2020-01-07 08:04:31] VERBOSE[11539][C-0003e584] pbx.c: Executing [*803414@ext-intercom:37] Dial(“SIP/3153-00064fe1”, “SIP/3414,5,IA(beep)b(autoanswer^s^1(ring-answer,;answer-after=0))”) in new stack
[2020-01-07 08:04:31] VERBOSE[11539][C-0003e584] app_dial.c: SIP/3414-00064fe3 is ringing
[2020-01-07 08:04:36] VERBOSE[11539][C-0003e584] app_dial.c: Nobody picked up in 5000 ms

(extension 3414 is a Digium D40, Firmware 2.9.2)


#2

Did you just upgrade to FreePBX14? what versions of everything are you running?


(Barry D. Hassler - HCST) #3

No, we’re still at 13… 13.0.197.21 specifically. We do want to upgrade to 14, but need to schedule time with console access as a “just in case”.


#4

Can you try getting a packet trace when an intercom call is made to that phone? We want to make sure the Alert Info header is getting set correctly in the INVITE packet.


#5

that’s what I’m thinking. I forget what version exactly but at some point in the past on 13, I think the core module changed and the alerts no longer worked due to formatting.

If it’s the same issue the solution is in this thread. you’ll need to manually modify the mariaDB column widths on one of the table. and then modify your alerts.


(Barry D. Hassler - HCST) #6

The INVITE packet is here:
https://pastebin.freepbx.org/view/ac06d963

Judging from the other answers, looks like the PBX is sending:
Alert-Info: http://127.0.0.1;info=ring-answer

But phone is expecting just the “info=ring-answer” if I’m understanding this correctly.


(Lorne Gaetz) #7

Make sure your phone firmware is up to date.


(Barry D. Hassler - HCST) #8

Phone firmware is at 2.9.2


#9

Take a look at Settings->Advanced Settings. In the Dialplan and Operational section, you’ll find an option named “Enforce RFC7462”. Try toggling that. When enabled(default), it will add stuff to the alert info value like you’re seeing. This can be an issue for some phones, but I’m surprised to see it causing an issue on your D40, assuming it’s configured through EPM. Still worth trying though.


(Barry D. Hassler - HCST) #10

Enforce RFC7462 was turned on, and I’ve toggled it off. Will have client test it again tomorrow. Thanks!


(Barry D. Hassler - HCST) #11

Finally got word back from my client testing the intercom feature again. It appears that turning off the “enforce RFC7462” was the trick. Should this be a bug issue or something so it gets resolved in regards to how the Digium phones handle the INVITE?


#12

Thanks for the status update. I plan to open an issue ticket if I can pinpoint the problem. The thing is, I’m also testing a D40 on 2.9.2, and it auto-answers successfully, whether that option is disabled or enabled. I verified that the INVITE packet sent to the phone changes the Alert-Info header appropriately when enabled/disabled. I still need to investigate further.


(system) closed #13

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.