Intercom not working from grandstreams, but working from PAP2T adapter

Hello I am running
PBX in a Flash Version 1.4 Daemon Status

  • Asterisk * ONLINE * Zaptel * ONLINE * MySQL * ONLINE *
  • SSH * ONLINE * Apache * ONLINE * Iptables * ONLINE *
  • Fail2ban * ONLINE * IP Connect* ONLINE * Ip6tables * ONLINE *
  • BlueTooth * ONLINE * Hidd * ONLINE * NTPD * ONLINE *
  • Sendmail * ONLINE * Samba * OFFLINE * Webmin * ONLINE *
  • Ethernet0 * ONLINE * Ethernet1 * N/A * Wlan0 * N/A *

  • Running Asterisk Version : Asterisk
  • Asterisk Source Version :
  • Zaptel Source Version :
  • Libpri Source Version : 1.4.9
  • Addons Source Version : 1.4.7

My paging\intercom is not working properly, I have searched this forum and the PBIAF forum. It is not the ztdummy issue as my conference is working fine and I have reloaded it just in case, also the intercom works when dialed from my cordless phone on the pap2t

I have a paging group set up with code 777 (I’ve also tried 778) with my 2 GXP2000’s in the group, set up with duplex, force if busy, and default group.

When I dial *80777 from my analog phone on a pap2t adapter both my gxp2000s intercoms work beautifully
When I dial *80777 from either of my gxp2000’s I get a 404 not found error
When I dial *80777 from my eyebeam softphone on my computer I get "The person you are calling is unavailable"
When I dail *80777 from my grandstream BT100 I get a 404 error code
When I try the workaround described on everything works fine. But all editing has to be done in the file, not on the freepbx web interface.

I thought the error might be caused by the gxp2000’s not sending the *80 code so I swapped the *80 with another code that was working. Then when I dialed the previously working code that was now assigned to paging, I got the same 404 error.

Ive gone into the CLI with asterisk -vvvvvr and I see a lot of activity when when I dial *80777 from the cordless phone on the PAP2T but absolutely nothing when I dial it from the grandstreams.

any thoughts?
Thank you.

Make sure all of your devices support paging/intercom.
Grandstream phones need to have “auto answer on call info” set

The *80 prefix is used to page on a single phone the syntax would be *80XXXX
where XXXX is the extension number.

Group paging is done by dialing just the group number, which, it appears in your case is 777.


Yea well don’t I feel dumb, I thought you always had to dial the *80. And it really threw me off that dialing *80777 worked from my cordless phone. That was the problem, operator error, thanks!