Intercom from same extension not working

I am wondering if this is just how it is or if I am overlooking something

PBX Version:
PBX Distro:12.7.8-2302-1.sng7
Asterisk Version:18.9

I have clients with 4 voip phones that have the same extension assigned to them.
lets say the extension is 500

They want to be able to intercom by dialing *80500 from one of the four phones and have the other 3 phones auto answer the intercom call.

The issue that I am having with the setup is if i try this from one of the 4 phones with the same extension I get a message “intercom for extension 500 is disables” even though it is enabled.

If I try the same thing from a phone on a different extension it works just like it should (all 4 phones auto answer the intercom call)

So why does it not work from one of the four phones with same extension?

Because when you answer a call, the extension 500 is ‘bound’ to the ip address of that phone, SIP would only send that new call back to you with negative effect,

So why has it worked in the past and now it doesn’t.

Sorry, never tried to ‘intercom’ myself :slight_smile: but perhaps someone figured out that that;s not a good idea.

I think this is happening because of FreePBX logic, not because of binding of an IP address. Even if this done using chan_pjsip multiple contacts, addresses are only bound to the contact, and that is at registration time, not call set up time. If it just done with & in the dial string, the Asterisk core has no idea that multiple endpoints correspond to the same Asterisk extension

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.