Intercom Auto-Answer capability with Aastra 480i IP Phones

This refers to FreePBX 2.2.0, Asterisk 1.2.14 and Aastra 480i firmware

FreePBX auto-generates extensions_additional.conf with the [ext-intercom] context containing a workable hands-free intercom section.

The problem is that the stock [ext-intercom] context won’t trigger the auto-answer-alert splash tone on Aastra 480i phones using firmware That firmware requires a special SIP header to activate the splash tone.

To make it work, you have to REPLACE line 7:

exten => _*80.,n,Set(__ALERT_INFO=Ring Answer)


exten => _*80.,n,Set(__SIPADDHEADER=Alert-Info: ;info=alert-autoanswer)

Unfortunately, every time that you use FreePBX to maintain extensions, it overwrites the changes.

I would like to know where in the FreePBX code this context is generated. I might be able to modify my copy of FreePBX, if I could just find the right module and the code.

Thanks in advance for any suggestions!

Can’t you put the functionality and special line into extensions_custom.conf which FreePBX does not generate or modify and not even use the FreePBX intercom feature?

Thanks for the response.

I hadn’t thought of that and so I gave it a try this afternoon. Unfortunately, your suggestion doesn’t work. I can copy the ext-intercom context to extensions_custom.conf (which is included), but as soon as I disable the Intercom feature, ICOM calls fail.

Enabling Intercom changes more than just extensions_additional.conf and the other changes won’t work in the extensions_custom.conf file. Nice try though :slight_smile:

So, I would like to just find out what code generates the ext-intercom context in extensions_additional.conf. With that, I might be able to easily fix the syntax.

Thanks again!