Interactive FOP problem / call problems

Hi all,

I have installed AsteriskNow in my home for testing purposes, I have updated it after installation and installed the last FOP version 0.30 and installed it. I have 2 issues in common that I can not resolve till now

1- When I drag extension in the FOP to dial another extension I found it call itself and not the other extension. This alway happen.

2- I have 2 softphones and 1 hardphone (SNOM 370) call from soft to soft working fine as well as from hard to soft, but when I try to call from softphone to hardphone I got error on the softphone client (Server unreachable / service unavailable) really very starnge and I can not figure out why.

I used the following softphones with the machines and the same happens with all

X-Lite, 3XCOM, Zopier



I tried dragging the phone in my FOP to another. I get the same result.

I am using FOP version 0.30. What version do you have?

Hmm… I don’t understand. Where do you connect the hardphone? Directly to one of the TDM?

What kind of TDM do you have?

In the FOP server, when it the extension calls itself, this is correct it should be answered to complete the FOP request.

In the second, the DND feature was somehow abnormal. but it worked now and everything is going fine. I use FOP 3.0

the hardphone is connected in the same LAN of Asterisk server

I was confused, thinking that the hardphone was an old-style RJ11 phone jack phone. You were talking about an IP hardphone. Got it.

So it seems that it was a setting in the phone itself?