Installing Zerotier on Raspberry Pi 3

I would like to install Zerotier on my raspberry pi 3 that i have had FreePBX running for years. I followed an example found on here but it keeps failing so does anyone have
a different way. GPg2 doesn’t work on my version FreePBX 14.0.17 on my pi 3
I tried google to find different ways and tried different installs but none have worked.
I have Zerotier working on several raspberry pi 3B with allstar hamvoip with great results.
Dave
wa2kjc

How does , when root,

apt install gnupg2

fail on your machine?

root@raspbx:~# apt install gnupg2
E: Malformed entry 1 in list file /etc/apt/sources.list.d/zerotier.list (Component)
E: The list of sources could not be read.
E: Malformed entry 1 in list file /etc/apt/sources.list.d/zerotier.list (Component)
E: The list of sources could not be read.
root@raspbx:~#

needs fixing

cat  /etc/apt/sources.list.d/zerotier.list

I ran it then i issued this
curl -s ‘https://install.zerotier.com/
and it downloaded a whole bunch
when i try to issue the command
sudo zerotier-cli help or listnetworks , no such command

i copied the result of the install.zerotier.com but i can’t seem to get it to you here
it’s in text format and pdf and 11 pages so i can send via email if you would like
wa2kjg at g mail

no , you need to post the content of zerotier.list

Hi dicko, thank you for your time and effort.
there is no zerotier.list
i rolled my sd card back to the starting point before i started to try and install zerotier so
i have a clean start again,
nothing i found on the internet is working for me, so your turn if you would please.
FreePBX has been working fine for years on the raspberry pi 3
what are you suggestions to install zerotier.
Dave

I disagree. from your first post

that is saying it existd nut line 1 is malformed

so are you going to give me instructions on how to install zerotier ?
all what i have done previously is gone , i told you i went back to
my original sd card image before i started trying to install zerotier.
i want to start fresh installing zerotier on my FreePBX raspberry pi 3
do you have a procedure please ?

Sorry, I can’t give you any better instructions than the ones on the zerotier install page which works for me, but if you care to you can

 curl -s https://install.zerotier.com -o zerotier.install 

and examine the generated file zerotier.install, lines 13-15 are a synopsis of what will happen and you can then

bash zerotier.install 

as many times as you want to debug why your list file is not created correctly (lines 221 or 214)