Installing UNISTIM on AsteriskNow! Beta 1.5

Hello, I am trying to install INISTIM support on my clean install of asterisknow 1.5; I have found and tried instructions for straight full version installs of Asterisk, but no help for astersisk now… I have tried the how to guides around online and haven’t had any success. Any Ideas? is it possible, or do I have to reinstall everything from stratch?

What I’ve tried & Referenced: - for version 1.4.x.

Any help you can provide is a huge help! Thanks, Andrew

Let me know if you make any progress on this.

I am interested in figuring out how to do the same.


The primary reason that the install directions given above fail is that it tries to install the Asterisk1.6 directions by default.

Have you tried:
yum -y install asterisk14-devel

This stopped the errors trying to download/install the module.

I then made a backup copy of unistim.conf
cp /etc/asterisk/unistim.conf /etc/asterisk/unistim.conf_old

Then edited unistim.conf:
(duplicated entire section “[black]”, making a new section “[Office21]”).
Removed all semicolons from the beginning of the lines.
Edited “device=000ae4…” line to match the Ethernet/MAC address of the i2004 phone.
Edited callerid=“Name” <555-555-1234>
Edited line to read “extension=line”

Went into FreePBX Web Interface, and added Extension, Custom, and put in the extension # to match.

Unistim phone boots okay and registers to the system.

When I pick up the i2004 and dial the extension number of the SIP phone, the SIP phone rings.
(Unfortunately, there is no audio path).

When I pick up the i2004 and dial “*43”, it says something about “Online”, but does not get me to the echo application.

When I pick up the SIP phone and dial the i2004, I get a “Error: Declined”.

I need to figure out if the problem resides with the dialplans, with another config file somewhere, or during call setup negotiation (i.e. non-matching RTP ranges).

Anybody have any other ideas of what to check, let me know.
The O’Reily Asterisk book hasn’t been too useful, as it doesn’t align with AsteriskNow1.5beta (Asterisk 1.4.25 + FreePBX).


I have been able to setup my UNISTIM devices as extension on my freepbx system but i’m having trouble figuring out how to enable voicemail on them. Also having trouble figuring out how to set them up as destinations in inbound routes, IVR’s, ring groups, etc. All of my SIP devices can do this easily… just not sure how to get the same fuctions on my UNISTIM devices.

munozj it’s been four years since anyone replied to this thread if that gives you any idea about the state of UNISTIM support in FreePBX. I’ve seen some stuff here and there about it, but it’s not a real hot topic, there are some dedicated hardware pieces to convert them to SIP, but most people find it’s less hassle and cheaper in the long run to update to newer SIP devices.