Installing onto Intel NUC NUC6CAYH

Hi everyone, firstly just want to say, great forum ive used it many times to help configure previous builds and get me out of the jam a couple of times :slight_smile:

I thought I would give one of these mini pc’s a go and I have brought one of these Intel NUC NUC6CAYH devices with 4gb ram and a 128gb ssd. I feel I have tried just about everything to get freepbx to install by USB.

I attempted to use my faithful usb that containes the 32bit latest build which failed at the point when I couldn’t find the kickstart file.

tried the 64bit latest build on usb and it instantly said I had unsupported hardware device intel cpu model

also tied the STABLE SNG7-PBX-64bit-1712-1 which appeared to be installing fine until it just goes to a blank black screen and nothing further happens from there…

is there anything you can suggest I do to help me get over this hurdle…

thanks in advance

Does this NUC have a supported processor for FreePBX13? Remember CentOS 6.6 isn’t supported by many newer Intel processors.

If you have a newer NUC with a processor unsupported by CentOS 6.6 you need to use FreePBX14. I can’t offer any advice why this isn’t working for you except to say I deploy plenty with no issues.

Your first step is to check both CentOS 6.6 and Centos 7 suppport for your processor.

IIRC, you are missing a video driver. I think you can install it after the fact through SSH.

thanks for your replies , it is the intel processor that isn’t supported. I installed it on a different machine and then transferred the HDD over and it has loaded up. the only issue I can see now is the Ethernet port isn’t working and I don’t have the knowledge to install a different driver? I have downloaded the driver onto a usb but don’t know what to do from here, can anybody help me with this please

Hi Steve , what model NUC have you successfully installed FreePBX onto… thanks

That’s a video driver issue. If you pick ‘Text Mode Install’, it will install without any need of interaction from you - and set the root password to be SangomaDefaultPassword

I’ve added that in the 1712 ISO exactly because of issues you’re having with new video drivers that haven’t made it into the kernel yet 8)