Installing Gnome breaks FreePBX gui

I am running FreePbx ver 16 with serveral Commercial Modules which are all up to date.
When I reboot the pbx and then try to log in, I get:

Whoops \ Exception \ ErrorException (E_ERROR)
Allowed memory size of 1073741824 bytes exhausted (tried to allocate 1935764547 bytes)


Whoops\Run handleError


// System Admin
// Copyright 2023 by Sangoma Technologies Inc., All rights reserved
// By installing, copying, downloading, distributing, inspecting or using
// the materials provided herewith, you agree to all of the terms of use as
// outlined in our End User Agreement which can be found and reviewed at
if(extension_loaded('ionCube Loader')){die('The file '.__FILE__." is corrupted.\n");}echo("\nScript error: the ".(($cli=(php_sapi_name()=='cli')) ?'ionCube':'<a href="">ionCube</a>')." Loader for PHP needs to be installed.\n\nThe ionCube Loader is the industry standard PHP extension for running protected PHP code,\nand can usually be added easily to a PHP installation.\n\nFor Loaders please visit".($cli?":\n\n\n\nFor":' <a href=""></a> and for')." an instructional video please see".($cli?":\n\n\n\n":' <a href=""></a> ')."\n\n");exit(199);
HR+cPoroQySGws/fxRV+v9wWEhOO6jjamccqK/CCjlQbmzNO/1d5P2dNZwjzzpPUBO57ONFjcs6u ......

I can temporarily resolve the issue until the next reboot by:
systemctl restart httpd.service
I can then load the gui fine and all appears well with the system.
I have tried several fwconsole commands to clean, reload etc. but no change to the results above.

Can anyone provide guidance as to where I should look to resolve this probem?
Thank you and regards.

Open a bugreport with FreePBX. [FREEPBX-8777] Blind transfer to virtual extensions not working - Sangoma Issue Tracker

Try setting memory_limit in the /etc/php.d/freepbx.ini and restarting httpd.

Tried changing memory limit but no success.
I have found that if I install Freebx from scratch, all works fine until I intall Gnome which I need for remote support purposes. This has worked wonderfully for years until now.
As soon a Gnome is installed, the error message occures.
By restarting httpd, the problem is temporarily resolved until the next restart,

I tried further inctreasing memory to 2048M and this sort of worked.
I do not now get the error message described above but I cannot access the FreePBX gui, no response to entering the ip address. If I then run systemctl restart httpd.service, which takes a long time to run, about 5 seconds, noramally it is instantaneous, I can then access the Freepbx gui.
Any ideas to resolve this greatfully received. :thinking:

Why do you feel the need for such a heavyweight remote access tool? FreePBX was designed to have the “whole machine” and running it alongside another big project such as Gnome is likely to cause trouble.

Some reasons why you can’t straightforwardly access the shell or GUI:

  1. You have a dynamic IP address. Just run a dynamic DNS client on the router/firewall, or on the PBX.

  2. The PBX is behind a NAT over which you have no administrative control. Try to get VPN access, or remote desktop access (RDP, TeamViewer, etc.) to another machine on the LAN, from which you can straightforwardly access the PBX. If the IT guys say no, consider autossh reverse tunnel or Wireguard to a cloud server or similar, unless they also prohibit that.

  3. Your ISP does not provide a public IP address, connecting you via CGNAT or 464XLAT (mobile broadband, Starlink, etc.) You have many obstacles besides remote support (no remote extensions, incompatible with many trunking providers, etc.) Rather than on-site, consider running the PBX in the cloud. But if you must run on-site, autossh should be workable across such a link.

I’m curious how Gnome is giving you remote access. If it’s via something like TeamViewer, you can run that without a GUI; see Install TeamViewer (Classic) on Linux without graphical user interface - TeamViewer Support . If you are running RDP, VNC, etc., you should be able to use the same path to get VPN access to the PBX.

With reference to your questions above:

  1. My customers pbx is on a network behind a router with a fixed wan IP. Their IT department does not allow me to get “direct access” via the router so I have had to workaround that restriction.

  2. To gain access we use a product called MeshCentral which we run on our own vps. Nice and secure. We have found that TeamViewer etc. on Centos 7 together with the restrictions of the sng distro (old) breaks from time to time and is a pain to update. Adduitionnally teamViewer is a little expensive for what we need as it would only be used forr this client. MeshCentral needs a gui (Gnome in this case) at the remote end. Additionally I use Gnome to update a couple of non-freepbx items such as fop2.

Accessing the pbx from an inhouse PC is something we do currently for pure pbx tasks but we still need the Gnome gui to accomplish some of the other things we want to do.
We use WireGuard at many of our other clients and if we could install that on Freepbx it would be wonderful. Unfortunately it will not install on the sng distro. Solve that, all my other issues go away!
We have installed a WireGuard hub on a vps and it proved to be very reliable, secure and fast.

  1. PBX in the cloud is not an preferred option for a variety of reasons.

I read your question again and I thought my answer could be clearer. We do not use Gnome to get remote access. We use MeshCentral, a bit like Teamviewer, which gives us access to the pbx via the Gnome gui installed on the PBX. If I had direct access via WireGuard … ahhh, I can only dream. In our other Freepbx sites we do not have go through this “work around” - I am being polite!

First, many thanks for your post – I had somehow not heard of MeshCentral, a very useful tool that I’ll surely be using in the future.

Regarding Wireguard, some have claimed success, for example

but I know nothing about the technical details.

Won’t get easier than

Try to install WireGuard and you get a very long list of dependency issues. The sng repo is an issue. I cannot even use Docker.
I have installed WireGuard clients on many non-freepbx systems and it has to be one of the easier installations.
@Dicko, I note your comment regarding installation of WireGuard and refer you to the thread you participated in Can I install wireguard on freepbx
As you can see, there is some effort in installing WireGuard on FreePBX and I would not be confident that some change in the distro would not break WireGuard. Maybe not, but keeping most everyting vanilla has worked well so far. Maybe I am just gun-shy!

As per your comment in that thread, I do not need to persue any more wampum :wink:

linux is case sensitive but if I can assume you mean me, then ‘good for you’ and thanks.

1 Like

I had success using ZeroTier.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.