Installed / updated the DAHDI module in freepbx ... dahdi not working anymore

today I ran in following probs.
I installed the freepbx modules for dahdi …

before installation: (1 x dahdi connect to external - context from-pstn … 1 x dahdi used as internal isdn bus ) here you see the config.

I used the openvox_dahdi-linux-complete-2.6.1+2.6.1.tar.gz package, cause of my 8 x port digium card.

Now, after installation / update of this dahdi in freepbx, nothing with dahdi works anymore.
No incoming - no outgoing call works.

-----------------------------------------------------------------------------
Name/username              Host                                    Dyn Forcerport ACL Port     Status     
277844/277844              192.168.134.103                          D              A  2049     OK (12 ms) 
668                        (Unspecified)                            D              A  0        UNKNOWN    
670/670                    192.168.134.100                          D              A  5060     OK (199 ms) 
671                        (Unspecified)                            D              A  0        UNKNOWN    
4 sip peers [Monitored: 2 online, 2 offline Unmonitored: 0 online, 0 offline]
-----------------------------------------------------------------------------------

    -= Registered Asterisk Dial Plan Hints =-
              *[email protected]           : ccss:                 State:Unavailable     Watchers  0
                    [email protected]           : SIP/670               State:Idle            Watchers  0
                 *[email protected]           : ccss:                 State:Unavailable     Watchers  0
                 *[email protected]           : ccss:SIP/670          State:Unavailable     Watchers  0
                 *[email protected]           : ccss:                 State:Unavailable     Watchers  0
                 *[email protected]           : ccss:                 State:Unavailable     Watchers  0
                 *[email protected]           : ccss:                 State:Unavailable     Watchers  0
                 *[email protected]           : ccss:                 State:Unavailable     Watchers  0
----------------
- 8 hints registered
-----------------------------------------------------------------------------------
Peer             User             Call ID          Extension        Last state     Type            Mailbox    Expiry
192.168.134.100  670              72ccec52ec3dad7  --               <none>         mwi             [email protected] 003600
1 active SIP subscription
-----------------------------------------------------------------------------------
Description                              Alarms  IRQ    bpviol CRC    Fra Codi Options  LBO
B4XXP (PCI) Card 0 Span 1                OK      0      0      0      CCS AMI           0 db (CSU)/0-133 feet (DSX-1)
B4XXP (PCI) Card 0 Span 2                RED     0      0      0      CCS AMI           0 db (CSU)/0-133 feet (DSX-1)
B4XXP (PCI) Card 0 Span 3                RED     0      0      0      CCS AMI           0 db (CSU)/0-133 feet (DSX-1)
B4XXP (PCI) Card 0 Span 4                YEL     0      0      0      CCS AMI           0 db (CSU)/0-133 feet (DSX-1)
B4XXP (PCI) Card 0 Span 5                RED     0      0      0      CCS AMI           0 db (CSU)/0-133 feet (DSX-1)
B4XXP (PCI) Card 0 Span 6                RED     0      0      0      CCS AMI           0 db (CSU)/0-133 feet (DSX-1)
B4XXP (PCI) Card 0 Span 7                RED     0      0      0      CCS AMI           0 db (CSU)/0-133 feet (DSX-1)
B4XXP (PCI) Card 0 Span 8                RED     0      0      0      CCS AMI           0 db (CSU)/0-133 feet (DSX-1)
-----------------------------------------------------------------------------------
   Chan Extension  Context         Language   MOH Interpret        Blocked    State     
 pseudo            default                    default                         In Service
      1            from-pstn       en         default                         In Service
      2            from-pstn       en         default                         In Service
     10            from-internal   en         default                         In Service
     11            from-internal   en         default                         In Service
-----------------------------------------------------------------------------------
PRI       B    Chan Call       PRI  Channel
Span Chan Chan Idle Level      Call Name
   1    1 Yes  Yes  Idle       No   
   1    2 Yes  Yes  Idle       No   
   4   10 Yes  No   Idle       No   
   4   11 Yes  No   Idle       No   
-----------------------------------------------------------------------------------
PRI span 1/0: Up, Active
PRI span 4/0: In Alarm, Down, Active
-----------------------------------------------------------------------------------
Primary D-channel: 12
Status: In Alarm, Down, Active
Switchtype: EuroISDN
Type: Network
Remote type: Unknown node type
Overlap Dial: 0
Logical Channel Mapping: 0
Timer and counter settings:
  N200: 3
  N202: 3
  K: 7
  T200: 1000
  T201: 1000
  T202: 10000
  T203: 10000
  T303: 4000
  T305: 30000
  T308: 4000
  T309: 6000
  T312: 6000
  T313: 4000
  T-HOLD: 4000
  T-RETRIEVE: 4000
  T-RESPONSE: 4000
  T-STATUS: 4000
  T-ACTIVATE: 10000
  T-DEACTIVATE: 4000
  T-INTERROGATE: 4000
  T-RETENTION: 30000
  T-CCBS1: 4000
  T-CCBS2: 2700000
  T-CCBS3: 20000
  T-CCBS4: 5000
  T-CCBS5: 3600000
  T-CCBS6: 3600000
  T-CCNR2: 10800000
  T-CCNR5: 11700000
  T-CCNR6: 11700000
Q931 RX: 0
Q931 TX: 0
Q921 RX: 0
Q921 TX: 1372
Q921 Outstanding: 0 (TEI=0)
Total active-calls:0 global:0
CC records:
Overlap Recv: No

--------------------------------------------------------------------------------------------

when i use asterisk -r , and can see the following in the logs :

a. incoming call — nothing in console
b. outgoing call —
– Executing [[email protected]:22] Dial(“SIP/670-00000005”, “DAHDI/g0/0151xxxxxxxx,300,tTrwW”) in new stack
– Requested transfer capability: 0x00 - SPEECH
– Called DAHDI/g0/015112XXXXXXXX
– Span 1: Channel 0/1 got hangup, cause 27
– DAHDI/i1/015112171132-3 is circuit-busy
– Hungup ‘DAHDI/i1/015112171132-3’
== Everyone is busy/congested at this time (1:0/1/0)


help is appreciated …

What does the module show? Are there errors on the dashboard?

Did you think to reconfigure the card after updating the module?

This are the things I figured out.

a. cat /etc/modprobe.d/dahdi.conf
options dahdi opermode=GERMANY alawoverride=1

This will not work, bceuase the openvox dahdi doesn#t know anything about the
parameter opermode … so it is not loading anymore.

b. You are overwriting this file
/etc/dahdi/system.conf

But the original setting for the wcb4xxp needs to stay in this way .

Autogenerated by /usr/sbin/dahdi_genconf on Tue Jan 15 18:02:43 2013

If you edit this file and execute /usr/sbin/dahdi_genconf again,

your manual changes will be LOST.

Dahdi Configuration File

This file is parsed by the Dahdi Configurator, dahdi_cfg

Span 1: B4/0/1 “B4XXP (PCI) Card 0 Span 1” (MASTER) AMI/CCS

span=1,1,0,ccs,ami

termtype: te

bchan=1-2
hardhdlc=3
echocanceller=mg2,1-2

Span 2: B4/0/2 “B4XXP (PCI) Card 0 Span 2” AMI/CCS RED

span=2,2,0,ccs,ami

termtype: te

bchan=4-5
hardhdlc=6
echocanceller=mg2,4-5

Span 3: B4/0/3 “B4XXP (PCI) Card 0 Span 3” AMI/CCS RED

span=3,3,0,ccs,ami

termtype: te

bchan=7-8
hardhdlc=9
echocanceller=mg2,7-8

Span 4: B4/0/4 “B4XXP (PCI) Card 0 Span 4” AMI/CCS YELLOW

span=4,0,0,ccs,ami

termtype: nt

bchan=10-11
hardhdlc=12
echocanceller=mg2,10-11

Span 5: B4/0/5 “B4XXP (PCI) Card 0 Span 5” AMI/CCS RED

span=5,0,0,ccs,ami

termtype: nt

bchan=13-14
hardhdlc=15
echocanceller=mg2,13-14

Span 6: B4/0/6 “B4XXP (PCI) Card 0 Span 6” AMI/CCS RED

span=6,4,0,ccs,ami

termtype: te

bchan=16-17
hardhdlc=18
echocanceller=mg2,16-17

Span 7: B4/0/7 “B4XXP (PCI) Card 0 Span 7” AMI/CCS RED

span=7,5,0,ccs,ami

termtype: te

bchan=19-20
hardhdlc=21
echocanceller=mg2,19-20

Span 8: B4/0/8 “B4XXP (PCI) Card 0 Span 8” AMI/CCS RED

span=8,6,0,ccs,ami

termtype: te

bchan=22-23
hardhdlc=24
echocanceller=mg2,22-23

Global data

loadzone = de
defaultzone = de


cat /etc/dahdi/modules

dahdi
wcb4xxp
dahdi_transcode
dahdi_echocan_oslec
dahdi_dummy


Also the wcb4xxp needs to be loaded with speacial parameters, otherwise
the difference between TE mode and NT Mode is not realized. Doesn’t matter
is the jumpers on the card were set in the right way.

modprobe wcb4xxp te_nt_override=231

So, so original dahdi and wcb4xxp (this is used for 4 Port and 8 Port ISDN Bri)
will not work.

This is, why I use the package from openvox.

latest : openvox_dahdi-linux-complete-2.6.1+2.6.1.tar.gz

a) You can uncheck using opermode in modeprobe settings and by default it’s not enabled so I am thinking you set that yourself. Therefore if it doesnt know anything about opermode disable it. Furthmore you are trying to set an option for the wcb4xxp on the card ‘dahdi’. Did you know you can change what module you are setting options for? Not sure if you knew that either.

b)No that is not true. The dahdi module has always over written system.conf and that is how it will remain. If you want to configure system.conf manually then do not use the dahdi module in freepbx. All of the settings you have listed in this file except ‘hardhdlc’ the dahdi module maintains. If you are using ‘usr/sbin/dahdi_genconf’ you shouldn’t be using the dahdi module at all. You see once you use the dahdi module you simply go in and set the settings for each digital card. You must do this through the module when you install it.

c) I am again thinking you didn’t look at the dahdi module at all. Did you know that in modprobe settings there is an area (at the bottom) where you can add custom settings. That is what YOU need to do. Add the setting there.

Please reference this link for more information: http://literature.schmoozecom.com/dahdi-module/userguide/Dahdi-Module-UserGuide.pdf

OK, thanks for your help.
In freepbx dahdi module there is the link for modprobe settings.
Great.
In that dropdown box you can disable any settings for dahdi and enable setting for the wcb4xxp module. Also individula parametre for modprobe settings could be set. great.
The settings were written into this file /etc/modprobe.d/dahdi.conf
options wcb4xxp te_nt_override=231

Then restarting the dahdi with /etc/init.d/dahdi restart … works great.
[email protected]:/etc/rc.d/init.d# ./dahdi start
Loading DAHDI hardware modules:
dahdi: [ OK ]
wcb4xxp: [ OK ]
dahdi_transcode: [ OK ]
dahdi_echocan_oslec: [ OK ]
dahdi_dummy: [ OK ]

driver should be ‘qozap’ but is actually 'wcb4xxp’
Running dahdi_cfg: [ OK ]


in debug

Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: NOTE: hardware echo cancellation has been disabled
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 1: TE mode manually set
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 1: TE mode
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 2: TE mode manually set
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 2: TE mode
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 3: TE mode manually set
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 3: TE mode
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 4: NT mode manually set
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 4: NT mode
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 5: NT mode manually set
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 5: NT mode
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 6: TE mode manually set
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 6: TE mode
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 7: TE mode manually set
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 7: TE mode
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 8: TE mode manually set
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Port 8: TE mode
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: Did not do the highestorder stuff
Jan 20 15:37:56 lintommi kernel: dahdi_transcode: Loaded.
Jan 20 15:37:56 lintommi kernel: dahdi_echocan_oslec: Registered echo canceler 'OSLEC’
Jan 20 15:37:56 lintommi kernel: wcb4xxp 0000:06:01.0: new card sync source: port 1
Jan 20 15:37:57 lintommi kernel: wcb4xxp 0000:06:01.0: new card sync source: port 1
Jan 20 15:37:57 lintommi kernel: wcb4xxp 0000:06:01.0: Span 7 has invalid sync priority (5), removing from sync source list
Jan 20 15:37:57 lintommi kernel: wcb4xxp 0000:06:01.0: Span 8 has invalid sync priority (6), removing from sync source list
Jan 20 15:37:57 lintommi kernel: dahdi_echocan_mg2: Registered echo canceler ‘MG2’

great … so the setting for this specific moddule in dahdi could be done.

Whats about the settings in /etc/dahdi/system.conf if they were always overriden ?

In the log above you can see, that the default installed /etc/init.d/dahdi script, which starts / stops / restarts the dahdi in redhat / centos / fedora / elastix etc always use the dahdi_cfg , which overrides the /etc/dahdi/system.conf.

Then, when freepbx starts, the dahdi module in freepbx overrides the /etc/dahdi/system.conf again. ??

Where to put all the needed /etc/dahdi/system.conf in freepbx … is there an dditional config file like for the others, that my settings for that card (see above) could be set ?

driver should be ‘qozap’ but is actually ‘wcb4xxp’. Did you check to see if you have that driver available in the list of modprobe settings. According to what you posted that driver is not a system wide driver! You said this

cat /etc/dahdi/modules

dahdi
wcb4xxp
dahdi_transcode
dahdi_echocan_oslec
dahdi_dummy

Did you attempt to look at the guide I proposed you read?

You haven’t even told us what version of the FreePBX Dahdi Module you are running!

As I said before you can add individual settings to system.conf in that same popup window for general settings in Dahdi Config. You shouldn’t be needing to add a whole lot there

Please read the guide.

When you make chnages in the dahdi settings, this are general settings, and
could not be done per channel. like hardhdlc
example: how to set hardhdlc and echocanceller per channel in dahdi module in freepbx?

/etc/dahdi/system.conf

Span 2: B4/0/2 “B4XXP (PCI) Card 0 Span 2” AMI/CCS RED

span=2,2,0,ccs,ami

termtype: te

bchan=4-5
hardhdlc=6
echocanceller=mg2,4-5

Which version I use ? I have written this down above.
openvox_dahdi-linux-complete-2.6.1+2.6.1.tar.gz

http://downloads.openvox.cn/pub/drivers/dahdi-linux-complete/releases/1.3.5/openvox_dahdi-linux-complete-2.6.1+2.6.1.tar.gz


I had a look at the guide, but this questions were not answered there.

driver should be ‘qozap’ but is actually 'wcb4xxp’
This message always appers when u use the wcb4xxp module from openvox.

No problem with this message. qozap+ not used anymore.

TH

sorry, I am using … just checking my freepbx box …

DAHDi Config - 2.10.7.1 - Schmoozecom - Disabled

TH

Was this resolved? I am experiencing similar issues, but it does not seem there was a resolution to this.

I dont understand the issue so I was of no help.