Installed certificate, can't access gui from chrome, how delete certificate from apache config?

I installed the default certificate that was auto-generated into the https setup. I shouldn’t have messed around with this, because currently, my server is completely behind a firewall anyway. But that’s what I did. I can no longer access the server through chrome. It gives me the error NET::ERR_CERT_INVALID. I accessed the server through edge, and that works. I created a new self-signed certificate, and imported that, but I still can’t access through chrome. Right now, I just want to turn off https access completely, but I can’t figure out how to de-import that certificate. I can’t disable the https admin port in system admin port management. I don’t know how to disable apache. What should I do?

Your problem is right there. You created a self-signed certificate. Chrome does not like self signed certificates. Just click “advanced” in the chrome screen and it will let you continue

Can I get rid of the certificate completely and turn off https? Chrome won’t let me continue even if I click advanced. If I delete the certificate in the manager, it is still imported into the apache config? I had changed the hostname on my server earlier on, could this be causing the problems? I really need some help with this. I can’t find documentation anywhere on how to turn off https.

What ended up working was to comment out the following lines in /etc/httpd/conf.d/ssl.conf like so:

#SSLEngine On
#SSLCertificateFile /etc/httpd/pki/webserver.crt
#SSLCertificateKeyFile /etc/httpd/pki/webserver.key

It seems to have disabled https, I just hope this won’t cause any other problems. I’ll update here if it does.

If I end up adding external access, I will probably get a certificate from LetsEncrypt, but until then, this seems to have worked.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.