Install FreePBX offline


I have RHEL 8.4 server without external internet access. Ive installed Asterisk 16 there (that wasnt easy), but everything broke at stage

./install -n

New SIPSettings installation detected. Initializing default settings

In Process.php line 1335:

The process “fwconsole extip” exceeded the timeout of 60 seconds.

Can i do freepbx installation without internet access ?

P.S. freepbx-latest.tar.gz is already at server

Can you not use the full Distro ISO? That way if you don’t have access you just won’t be able to update or activate it?

Im not using full disto, im instlling everything at clean RHEL 8.4 OS

Yes, i know, that i`ll dont have access to updates, but that is ok

I know you are using RHEL 8.4, I’m asking why you are not using the full distro? If you don’t have internet access this will be your best option. Otherwise you will probably be spending ages working around things when this will do what you need it to.

unfortunately, i have no such options. RHEL is working on virtualisation system, and i dont have permissions to use my own iso images

Someone else maybe able to help more than me, but sounds like you are setting yourself up for a major headache. Better off with an environment with internet access or one that supports ISOs.

Is it possible to install FreePBX on an Internet-connected system that has just a “base” CentOS system, e.g. a VM in DigitalOcean, but where you cannot start from an ISO?

The wiki has several articles contributed by both Sangoma and by end-users with instructions for a manual install on different versions of Linux.

Yes, i know how to install FreePBX at clean OS, but i doesn`t have internet connection, that is a problem

Ok, i partly solved that issue, ive installed FreePBX at my local server and rsynced /var/www/html directore and Asterisk database to that isolated server. Everything works fine (at first sign), extensions creates, deletes and uptades, but when im pressing Apply config button, i`m getting this error.

Error: Did not receive valid response from server

XHR response code: 504 XHR responseText: undefined jQuery status: error

While settings actually apllies. Server has a lot of security restrictions and i had to add user asterisk to crontab.allow and to solve issue with fwconsole executing. But now i just doesnt receive answer with Apply config, while other pages opens normally. What could it be ?

permissions to /var/lib/php/session/ are correct

-rw------- 1 asterisk asterisk 62 Aug 26 17:15 sess_123
-rw-rw-r-- 1 asterisk asterisk 62 Aug 25 22:53 sess_234
-rw-rw-r-- 1 asterisk asterisk 577 Aug 26 17:57 sess_345

Try fwconsole chown

This should set all the correct permissions.

tried. unfortunately didnt help

I wonder, why all other pages opens normally, while i receive that error only with Apply Config button

YAhooooooo!!! Solved :slight_smile:

Here is issue with Apply config

[2021-08-26 12:52:08] [freepbx.INFO]: GPG command took too long to run.
[2021-08-26 12:52:08] [freepbx.INFO]: Tried to refresh keys and failed with: GPG took too long to run the command:

Here is solution;

sudo fwconsole setting SIGNATURECHECK 0

sudo fwconsole reload

Thank you for help !!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.