Inmediate on-hold music on incoming calls, no ringtone to who is calling

I have an ongoing issue for a while with incoming calls. It’s been going on (and off) since our last upgrade a few months back.

Incoming calls to our main DID via a trunk seem to get immediately answered and receive our on hold music. This is… if I call from my mobile I don’t get “ring” tones until any extension answers. It immediately seems to connect and reproduce the internal music.

I understand this is not a correct behaviour as it means a call cost to whoever is calling even if we decided not yo answer.

I’ve read regarding fax detection issues but we seem to have everything disabled for faxes and I am completely lost in where to look. Any help would be appreciated.

This is the trace I see on our CDR log list.

|Time|Event Type|UniqueID|LinkedID|Cid num|Extension|Context|Channel Name|
| --- | --- | --- | --- | --- | --- | --- | --- |
|Tue, Nov 30, 2021 2:28 PM|HANGUP|1638278890.1028|1638278890.1027|12|699|from-internal|SIP/12-000003e6|
|Tue, Nov 30, 2021 2:28 PM|CHAN_END|1638278890.1028|1638278890.1027|12|699|from-internal|SIP/12-000003e6|
|Tue, Nov 30, 2021 2:28 PM|HANGUP|1638278890.1027|1638278890.1027|3460696xx02|h|ext-group|SIP/FonyTech_2-000003e5|
|Tue, Nov 30, 2021 2:28 PM|CHAN_END|1638278890.1027|1638278890.1027|3460696xx02|h|ext-group|SIP/FonyTech_2-000003e5|
|Tue, Nov 30, 2021 2:28 PM|LINKEDID_END|1638278890.1027|1638278890.1027|3460696xx02|h|ext-group|SIP/FonyTech_2-000003e5|
|Tue, Nov 30, 2021 2:28 PM|CHAN_START|1638278890.1027|1638278890.1027|3460696xx02|34952474848|from-pstn|SIP/FonyTech_2-000003e5|
|Tue, Nov 30, 2021 2:28 PM|CHAN_START|1638278890.1028|1638278890.1027|12|s|from-internal|SI|

Is your inbound route going to a ring group or a queue? If so, you will need to manually select “Ring Only” for “Music on Hold Class”.



Hi @scanady. It’s going to a time condition and then to a ring group.
We’ve adjusted this on the inbound route for the DID and currently seems to work correctly, but we’ve had this before and then the issue has returned so still not 100% that solved it.

I’m not sure you need to use Signal RINGING, but I’m also running Sangoma phones and my US provider doesn’t require it.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.