Initial Setup Firewall issues (from 2203-2 iso install)

Hey Team,

I’ve had a consistent issue when setting up new servers for some time (2+ years) but am only just finding time to be bothered to ask if anyone else is struggling.

Installing on a clean VM (tried Linode, Vultr, local XCP-ng) using either 2203-2 iso or 2204-01 (depending on what ISO I have uploaded where), I use the following procedure;


  • Boot from ISO
  • Select the recommended options by pressing enter 3 times
  • Click to set the root password, enter strong password,click done (top left) when correct.
  • Leave the installation running, Go make coffee.
  • When install finishes, eject media, hit the reboot button

Initial Setup part 1

  • Head to web interface
  • Enter admin user username
  • Enter [email protected] in the notification section
  • Enter the hostname in the system identifier box
  • Click setup system

Initial Setup part 2

  • Activate server using [email protected]
  • Continue, skip entering any additional details
  • New activation, enter descriptive name for the location (customer name)
  • Activate
  • Skip any adverts
  • Skip module updates
  • Select english (UK) and continue
  • Hit “Continue” to activate the responsive firewall
  • Next,
  • Yes (add my current IP/32 to trusted)
  • No (whole local net is not trusted)

That’s it, at this point I start getting red banners saying “undefined” and the process goes no further. Generally speaking if I now reboot the server, head back to the web interface and try again it works.

Now, it quite clearly says at the start of the firewall setup bit that " At the completion of this wizard, the firewall will be automatically enabled." but it looks like it’s getting enabled part way through the process and is, for some reason, locking me out…

Any ideas?

Looks like it might be breaking a step before I thought it was.

I just left it at the current network page without clicking Abort/No/Yes and the “undefined” error popped up. Web interface unresponsive, ssh connection attempts timing out.

I have experienced inconsistent behavior when enabling the firewall during initial setup. To avoid it, I click Abort on the firewall screen and proceed. Then I go to Connectivity - Firewall and set it up later. This has worked well.

So, do we think that this should be reported as a bug? I’ve no idea where or how to do that but happy to if others are having the same issues.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.