Initial call routing

I have just moved my functional system from a virtual machine to a docker.
I created and exported a backup of the old distro I was using and imported it to what looks like a much newer and sleeker version.
Every update I could throw at it is complete.

I have functionality, can make internal calls and external through the Obi110 box.

Slight issue in that all incoming external calls are are answered by a FreePBX Voice saying that “the number you have dialled is not in service, please check the number and dial again”

It should go to a recorded announcement > IVR > press 1 > then out to ring group.

It seems the Obi is handing the call to the server, but the server isnt handling the call the right way.

Been a long time since I built this, with help and im a little confused as to where I should be looking.

I tried changing the routing for the call - so that any incoming call goes direct to a working extension (removing the announcements, IVR, ring group) and it does the same thing.

Based on that description, it looks like the inbound call is being treated as an anonymous call. Your trunk config does not match the INVITE details.

Thank you.

Edit - I have just found the security settings for allow anonymous. See if thats the issue.

Here is the SIP conifg from the trunk settings if thats any help.


And thats exactly what the problem was.

Consider it solved. Thank you

That is never the solution. It is only a work-around until you get your SIP settings configured correctly. In your “permit-match” field in the PJ-SIP settings, you need to list the IP address of the OBI so that it can correctly authenticate.

Okay I’ll do that - I dont think I have Pj-SIP setup though - this was an old (neglected build) which I think just uses SIP.

Do I / Can I / Should I be moving this across from the labelled “legacy” SIP ?

The problem with Chan-SIP is that anything that needs to connect is going to need its own trunk definition, and modern providers are setting up POPs with dozens or hundreds of possible inbound addresses.

Since you’re using an OBI, you should be able to get by with just making sure the IP address of the OBI is set correctly in the Chan-SIP configuration.

In the long term, yeah, you need to move forward from Chan-SIP - it’s deprecated and being removed.

The SIP config you posted does not have a ‘host’ parameter, so the PBX would not know how to reach the OBi for an outgoing call. Do you have a separate trunk for outgoing?

If you add
to your trunk configuration and configure the OBi to register with the PBX, that should solve your inbound problem.

1 Like

Moving forward from Chan_SIP to pj_SIP - will my phones support that move?


Is that where I need to put the OBI IP address ?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.