Incomming Calls

trying to get incoming calls working, but im hitting a brick wall and im forced to seek a bit of help {}

getting an error SIP/2.0 488 Not Acceptable Here

ERROR[2707] res_pjsip_session.c: Vonage: Couldn’t negotiate stream 0:audio-0:audio:sendrecv (nothing)

but under my sip setting the codecs are selected

o=Nexmo 577021829 577021829 IN IP4
c=IN IP4
t=0 0
m=audio 22896 RTP/AVP 8 0 97 18 9 101
a=rtpmap:8 PCMA/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:97 iLBC/8000
a=fmtp:97 mode=30
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:9 G722/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16

any help would be good

<--- Received SIP request (402 bytes) from UDP: --->ACK sip:44 - for log

They are not offering media encryption. Confirm that anything to do with SRTP is off at your end. Or, if you want encryption, turn it on at the provider.

Putting the source file name into Google produced this video as the second hit:

It’s possible that this turns off more than you actually need to, but it is basically what Stewart is saying.

i tried all that, but i will go over it again and double check all the SRTP bits are off.

yeah tried it again rebooted still have this issue, made sure there is a matching codec within the settings/sip settings/general settings

does pjsip have its own codec section ?

Any more ideas i could check ?

no matter, ive fixed it, on the outbound trunk i had media encription set to SRTP via in SDP selected, i changed that to none, we incoming call.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.