Incoming SIP calls dont work


I’ve got FreePBX up and running and it’s working fine for external calls (via a sip trunk)

However incoming calls don’t work (caller recieves an out of service tone)

I spoke to the SIP provider who said this:

“I can see our server is polling your box with inbound SIP headers for the call, but it appear that you are not responding, as in a wireshark, I can see no responses to our requests at all. I can see plenty of jabber between the boxes keeping the session alive, but nothing that indicates a reply header from your Asterisk. With this in mind, I suspect you are filtering by DDI perhaps and dropping the traffic? I hope that at least narrows down the potential point of issue, sadly apparently to your server config, although a quick look at the logs should soon show where these are not being accepted.”

Could anyone help me to diagnose the issue? In my incoming route I dont have anything in the DID or CID fields.


Ok, i’ll try and provide as much info as possible but please let me know if I need to send anything else.

I used the AsteriskNow! ISO which also included FreePBX. It’s version It was just a standard install I haven’t changed anything other than configuring it with the GUI.

It’s installed on a server with a routeable public IP, i.e. no NAT.

These are the outgoing settings for my trunk, I didn’t specify anything for inbound.


From the console output when I try and make an inbound call it just shows the following lines and nothing else:

Using SIP RTP TOS bits 184
Using SIP RTP CoS mark 5

Any help appreciated


Mondeo -

Here is the assumptions. Since you have not taken the time to read any of the “how to ask for help” posts and included relevant information such as your system and version numbers, trunk information, what changes you have tried to the trunk to get it to work, console logs when an incoming call is received, SIP traces from an incoming call and inbound router information I have to make the assumption that you have also not spent time reading the SIP setup information on Asterisk and how it applies to an Asterisk system powered by FreePBX.

If you want help you need to do the lifting and send the information (formatted properly or for long logs linked via or the chances are slight you are going to be able to get this running.

Where are the how to ask for help posts?, i’ll gladly read them and comply with sending more detailed information.

I tried to search for “how to ask for help” but it didn’t bring anything up.


Then that’s likely the problem.

You should have a DID entry that matches the actual DID.

probably so with a country code “62” and area code “34” and actual number “12345678” it would be something like something like _624312345678 (including the underscore)