Incoming Route DID formatting UDP and TLS requires a different DID format

I’ve begun the journey of converting my trunk from UDP to TLS.

When I am using a UDP trunk my USA DID is set as _2223334444

When I am using a TLS trunk the _ seems to have no effect and I need to set the USA DID as 12223334444. If I have the DID set as _2223334444 while using the TLS trunk, it doesn’t work.

Where should I start this troubleshooting party? Perhaps some logs with “pjsip set logger on” ?

I think the _ has not real effect here. It looks like they have changed from national number dialled format, to international number dialled format, 1 being the country code for the USA. The new format is probably preferable, so it is best to change, or duplicate, your incoming routes, but you could try asking the provider if they could revert to the old format.

_2222 is not a proper dialling code format. Also this has nothing to do with UDP or TCP. You need send the caller ID is e164 format. You dialling code should just be the number including country code + local code followed by a “.” dot. eg. for UK would be 447. for UK mobile or for USA would be 18x. etc. Also you need to change the trunk settings for outbound for e164 format.

and for inbound its set to