Incoming calls ring very slowly

I have a pi running raspbx, and I have posted about this in raspbx, and done everything listsed there to ensure that this isn’t a raspbx issue. I am running freepbx Asterisk, it says “Ver. 11.17.0”. As far as I am aware everyihgt is up to date.

  • UK landline coming into a Cisco SPA232D
  • ‘hard’ phone on the other ‘side’ of the SPA232D
  • softphones on various devices

I happen to have a loud ‘ringing device’ on the phone line before the SPA232D, it is a legacy device that means I can hear calls in the garden. Calls from softphone to softphone (or even soft phone to the ‘hard’ phone the other side of the 232) takes typically less than a second from dial to ring.

A note: As I am in the UK the sequence on the line is:

  • Line reversal (which the ‘ringing device’ makes a ring ‘ding’ for)
  • Caller ID information is transmitted.
  • First ring.

However, incoming calls on the landline take a long time to ring, in the order of 3 and a half ringtones on the ringing device. I have watched the full log as it appears during a call. At the start of the first ring (ie after the line reversal and the CID information) it starts to log things. It is active for 2-3 seconds, about 1 of which is attributable to caller name look up. Then there is a long pause before the phones actually ring.

Now, I can reduce this delay by changing a setting on the spa232 but I am not sure if this is a good solution, and it raises a question about freepbx. What I did was to shortened SIP time T1 from 0.5s to 0.1s. As I understand it, this means the the SPA will take 0.1 seconds between the first invite to raspbx and the second one, rather than 0.5 seconds. The third will be after another 0.2 rather than 1.0 and so on, the gap doubling each time.

This suggests that asterisk/freepbx has a three step process here:

  1. Receive invite and do all the processing to be ready to invite the actual sip phones.
  2. Wait for the repeated invite to be sure it is a live call.
  3. Invite the sip phones.

Is this really the case? Is it possible to skip step 2?

Is this a sensible solution? What is the right way to speed up the ringing? It is such a long lag that it makes the system unusable for other users - they hear the first ring on the ringing device and then wonder why the phone isn’t working!

That is probably because your SPA is not dialing an unambiguous “extension”. I would contrive to add a # to the number dialed by the SPA when talking to the Asterisk box, the # will indicate a completed dialstring, or make sure your dialplan is unambiguous.

Also ensure that the SPA and Asterisk agree on the locale being used for “indications” and DTMF signalling.

1 Like

Many thanks for replying. I’ve tried to go through your suggestions systematically:

  1. Use an unambigious extension. I changed the SPA dial plan from “(<:@>S0)” to “(<:[email protected]>S0)” where XXX is the ring group I want to ring. No change. I also tried “XXX#” and “#” instead of “XXX”. No change.

  2. DTMF. On the asterisk trunk I have “dtmfmode=rfc2833” set, no obvious place to set this on the SPA232.

  3. “indications”, sorry, you’ve lost me here, I can’t find them listed (or “locale”) anywhere on the SPA232.

All further suggestions gratefully received!

I had different dtmf problems on my sipura and found this link which fixed for me:

can’t say for certain that it will fix problem your experiencing.

Thanks @alexcal, I’ve certainly improved my set up, but, sadly, it doesn’t seem to speed things up!

Did you ever get this fixed, Neil? I’ve noticed calls from the PSTN which are routed to my Asterisk instance first by a SPA3000 takes maybe 5 seconds or so before the telephone actually rings.

@dan_ce Afraid not. In the end, I ran out of time to invest, and it was clear that, sadly, a raspberry pun of that era simply didn’t have the power to achieve the speed and I ditched the project. I shoved freepbx on an old laptop PC where it runs smoothly as a voicemail service. But I never did examine any other issue further, sorry.