Incoming calls randomly answered by playback message - Help_Thanks

Some incoming calls go straight to playback message: “The number you dialed is not in service please check your number and dial again”

Inbound route Set Destination: ring group

PBX Hosted on CyberLynk:

SIP provider is sending calls in on IP’s other than the one the trunk registers on you’ll need to make sure that under Asterisk SIP Settings you have:

  • Allow Anonymous inbound SIP calls set to “yes”
  • Allow SIP Guests set to “yes”.

1. Question: Should I enable Anonymous inbound SIP calls set to “yes”??

PBX Firmware: 6.12.65-20
PBX Service Pack:

Trunk provider VoIP Innovations

4 Trunks
(attached images)
ps1466196131*CLI> sip show settings

Global Settings:

UDP Bindaddress:
TCP SIP Bindaddress: Disabled
TLS SIP Bindaddress: Disabled
Videosupport: No
Textsupport: No
Ignore SDP sess. ver.: No
AutoCreate Peer: Off
Match Auth Username: No
Allow unknown access: Yes
Allow subscriptions: Yes
Allow overlap dialing: Yes
Allow promisc. redir: No
Enable call counters: No
SIP domain support: No
Realm. auth: No
Our auth realm asterisk
Use domains as realms: No
Call to non-local dom.: Yes
URI user is phone no: No
Always auth rejects: Yes
Direct RTP setup: No
User Agent: FPBX-
SDP Session Name: Asterisk PBX 11.21.2
SDP Owner Name: root
Reg. context: (not set)
Regexten on Qualify: No
Trust RPID: No
Send RPID: No
Legacy userfield parse: No
Send Diversion: Yes
Caller ID: Unknown
From: Domain:
Record SIP history: Off
Call Events: On
Auth. Failure Events: Off
T.38 support: No
T.38 EC mode: Unknown
T.38 MaxDtgrm: 4294967295
SIP realtime: Disabled
Qualify Freq : 60000 ms
Q.850 Reason header: No

Network QoS Settings:

IP ToS RTP audio: EF
IP ToS RTP video: AF41
IP ToS RTP text: CS0
802.1p CoS SIP: 4
802.1p CoS RTP audio: 5
802.1p CoS RTP video: 6
802.1p CoS RTP text: 5
Jitterbuffer enabled: No

Network Settings:

SIP address remapping: Enabled using externaddr
Externrefresh: 10

Global Signalling Settings:

Codecs: (gsm|ulaw|alaw)
Codec Order: ulaw:20,alaw:20,gsm:20
Relax DTMF: No
RFC2833 Compensation: No
Symmetric RTP: Yes
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 30
RTP Hold Timeout: 300
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: No
Pedantic SIP support: Yes
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Sub. min duration 60 secs
Sub. max duration: 3600 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Outbound reg. retry 403:0
Notify ringing state: Yes
Include CID: No
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No
Outb. proxy:
Session Timers: Accept
Session Refresher: uas
Session Expires: 1800 secs
Session Min-SE: 90 secs
Timer T1: 500
Timer T1 minimum: 100
Timer B: 32000
No premature media: Yes
Max forwards: 70

Default Settings:

Allowed transports: UDP
Outbound transport: UDP
Context: from-sip-external
Record on feature: automon
Record off feature: automon
Force rport: Yes
DTMF: rfc2833
Qualify: 0
Keepalive: 0
Use ClientCode: No
Progress inband: Never
Tone zone:
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: *97

2. Any other setting I’ve have to change?

Thanks for the help

Two things:

  1. I use VI for all of my inbound calling, and they will only send traffic to the single, specific address I specified when I set up the trunk with them. They send traffic from a couple of addresses, but this is always a manageable number of sources (two or three, depending on your package and rate desk). Your assertion that they are sending traffic to more than one address does not gibe with my 10+ years of experience. You will need to set up a trunk for each incoming IP address and open your firewall to their traffic. Looking through your config files, I’d say you’ve probably got that covered.

  2. Never, under any circumstances, should you turn on Allow SIP guests or Allow Anonymous Inbound. One user here had $10,000 worth of long-distance calls on his system one month because of those. Repeating, just in case you didn’t get it: DO NOT ENABLE ANONYMOUS INBOUND or SIP GUESTS.

This message does not typically originate in your server. It is a VI message saying that your machine did not respond correctly to their incoming traffic. If you are sending this message, it means you do not have an “ANY/ANY” inbound route set up. You should do that if you haven’t yet.

Other than that, I don’t see any real problems with your setup. I noticed that your default codecs include uLaw, aLaw, and GSM, but your trunks were all set up with uLaw only. Shouldn’t be a big problem, but if you are looking for things to tighten up, that’s one possibility.

1 Like

First and most important, thanks for taking time to reply and point me in the right direction

I’ve took screen shoot from a PBX CDR, this call resulted on the following error

“The number you dialed is not in service please check your number and dial again”

VI checked and said the call was delivered to my IP, I’m not sure but the “Playback” may prove their point.

not sure how to troubleshoot this random issue. :rotating_light:

OK - since the message did come from your system, you need to go back to the /var/log/asterisk/full log file (probably the one from a couple of days ago, since they rotate out on a daily basis) and look at the sequence of events from the log that lead to the playback.

You have the time stamp from the call, so it should be relatively simple to get back to the right call and find the error.