Incoming calls not working


We are having trouble with incoming calls not coming through… We are using Twilio SIP (using pjsip driver) trunks with TLS. Outbound calls work perfectly, but every time I try to make an inbound call (from an external number) all I get is a busy signal.

I setup the NAT rule in our firewall to the FreePBX server and I confirmed that the traffic on port 5061 is being allowed. Also when I run a tcpdump on the FreePBX server it appears that there is traffic coming into the server when I make an inbound call, but I still just get a busy signal. I also tried completely disabling the firewall within FreePBX to see if that would make a difference, but it did not.

I do have the inbound route setup to my extension (softphone)… What am I missing here to get the inbound calling to work?

Thanks in advance!

One thing I found is that if I disable TLS then both inbound/outbound calls work fine.

That tells me that there’s something wrong with the Twilio guide to enabling TLS (page 12). Does anyone know what’s missing?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.