Incoming calls not work “the number have you dialed is not in service”

freepbx
endpoint
Tags: #<Tag:0x00007f7033a88428> #<Tag:0x00007f7033a8fdb8>

(Verónica De Los Santos) #1

Hello, I have problem with my incoming calls, all the time ring and sound a message “the number have you dialed is not in service” this only if I put to accept guest calls; but if I change this option to don’t accept guest calls, I get a busy ring, I don’t know what is happening.

My outbound calls working well, my trunk registered ok, I have five voicePulse as a provider and the “view calls record” registry all the incoming calls that I made. I’m noob in this, I review the trunk settings, the SIP Settings, RTP ports ranges and I failed to find the fault.

This is my peer details in the Trunk, I try changing the context for “from-pstn” but don’t work either.

type=peer
trustrpid=yes
rfc2833compensate=yes
qualify=yes
insecure=port,invite
host=myhost.voicepulse.com
dtmfmode=rfc2833
disallow=all
context=default
allow=ulaw

I appreciate your help and sorry for the bad English.


#2

The call is apparently being sent from an IP address different from what ‘myhost.voicepulse.com’ resolves to, so the call is not recognized as belonging to your trunk. It appears that VP has a list of possible addresses:
https://support.voicepulse.com/hc/en-us/articles/203177135-What-do-I-need-to-allow-in-my-firewall-settings-

I suggest that you switch to a pjsip trunk, where you can list the addresses in the Match (Permit) field.

If for some reason you are stuck with chan_sip, you would need to create a trunk for each address from which they send your calls (which may be far fewer than their complete list). However, this is not a robust solution; if you really need chan_sip, please explain.


(Verónica De Los Santos) #3

thank you very much for answering,

In voicepulse I have IP authentication , could I be receiving calls from different IPs?

I change the trunk to a PJSIP trunk, and successfully registered appears with available status, but I keep getting the same message “the number have you dialed is not in service”, any other idea.

Thanks


#4

Confirm that you have set the Match (Permit) field of your trunk with the list of addresses from which VP can send calls.

If you still have trouble, see whether the source address in the log for a failing call is in that list.


(Verónica De Los Santos) #5

yes the source address is included in the Match (permit) field.

I do a debug and this showed me when making the call.

<— Transmitting SIP response (499 bytes) to UDP:XX.XX.XX.249:5060 —>
SIP/2.0 100 Trying
Via: SIP/2.0/UDP XX.XX.XX.249:5060;rport=5060;received=XX.XX.XX.249;branch=z9hG4bK274b.40732771.0
Via: SIP/2.0/UDP XX.XX.XX.251:5060;rport=5060;received=XX.XX.XX.251;branch=z9hG4bK501e7699
Record-Route: sip:XX.XX.XX.249;lr
Call-ID: 3cbc541346e7912f589d2ce759edea2b@XX.XX.XX.251:5060
From: “Unavailable” sip:+52XXXXXXXXXX@XX.XX.XX.251;tag=as0dcce403
To: sip:+15125380000@XXX.XXX.XXX.196
CSeq: 102 INVITE
Server: FPBX-15.0.17.17(16.15.1)
Content-Length: 0

-- Executing [+15125380000@from-pstn:1] Set("PJSIP/Voicepulse_FIVE_pjsip-00000006", "__FROM_DID=+15125380000") in new stack
-- Executing [+15125380000@from-pstn:2] NoOp("PJSIP/Voicepulse_FIVE_pjsip-00000006", "Received an unknown call with DID set to +15125380000") in new stack
-- Executing [+15125380000@from-pstn:3] Goto("PJSIP/Voicepulse_FIVE_pjsip-00000006", "s,a2") in new stack
-- Goto (from-pstn,s,2)
-- Executing [s@from-pstn:2] Answer("PJSIP/Voicepulse_FIVE_pjsip-00000006", "") in new stack
   > 0x7fe05831b430 -- Strict RTP learning after remote address set to: XX.XX.XX.251:16116

<— Transmitting SIP response (1033 bytes) to UDP:XX.XX.XX.249:5060 —>
SIP/2.0 200 OK
Via: SIP/2.0/UDP XX.XX.XX.249:5060;rport=5060;received=XX.XX.XX.249;branch=z9hG4bK274b.40732771.0
Via: SIP/2.0/UDP XX.XX.XX.251:5060;rport=5060;received=XX.XX.XX.251;branch=z9hG4bK501e7699
Record-Route: sip:XX.XX.XX.249;lr
Call-ID: 3cbc541346e7912f589d2ce759edea2b@XX.XX.XX.251:5060
From: “Unavailable” sip:+52XXXXXXXXXX@XX.XX.XX.251;tag=as0dcce403
To: sip:+15125380000@XXX.XXX.XXX.196;tag=008376bc-69a4-43a7-9523-b36586794b6c
CSeq: 102 INVITE
Server: FPBX-15.0.17.17(16.15.1)
Contact: sip:XXX.XXX.XXX.196:5060
Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, MESSAGE, REFER
Supported: 100rel, timer, replaces, norefersub
Content-Type: application/sdp
Content-Length: 267


#6

Confirm that you have an Inbound Route with DID set to +15125380000 and CID set to any.


(Verónica De Los Santos) #7

yes I have it with that configuration and destination to a extension where working the outbound calls.


(Verónica De Los Santos) #8

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


(Verónica De Los Santos) #9

I delete the inbound route and add again, and modified the Client URI in the advanced settings trunk, I was missing the “+” before the user (15125380000) and put like this +15125380000 followed by @[ip]:[port], and now is working!

Thanks so much for your help!!