Incoming calls going straight to mailbox

i need some help with my PBX…

every couple days incoming calls are sent straight to mailbox.
if i reload the configuration everything works fine for a couple of days and then it starts sending incoming calls again straight to mailbox

EDIT: if i call my extension internally it is reachable

outgoing calls work all the time

the incoming calls are normally sent to a ring group wit the “ring all strategy”

FreePBX 16.0.19 Asterisk 18.12.1

here are my LOG files:




if more logs or any other data needed please let me know

[2022-06-11 13:23:33] WARNING[4673][C-00000003]: res_agi.c:2035 handle_connection: Connecting to '' failed for url 'agi://': Connection refused
[2022-06-11 13:23:33] WARNING[4673][C-00000003]: res_agi.c:2095 launch_netscript: Couldn't connect to any host.  FastAGI failed.

This comes up in:

however it isn’t particular useful, an it seems to me that the it was invalidly rejected, as the AGI server is, presumably, managed by FreePBX.

1 Like

thanks @david55

i did a fwconsole restart and got the message

[[email protected] ~]# fwconsole restart
Running FreePBX shutdown...

Running Asterisk pre from Core module
Stopping Call Transfer Monitoring Service
Core FastAGI Server is not running

after the restart incoming calls are working again…

now i need to find out why the FastAgi Server stops running…

It would be great to know what’s going on here, but a quick work around would be to disable the fastagi option in aadvanced settings.

thanks @lgaetz

if you need any logs or data let me know

i assume i need to reboot after disabling FastAGI in advanced settings…


i disabled FastAGI in advanced settings, incoming calls work fine but now when i pick up a call on one extension i get a missed call on all extensions even on the extension i picked the call up…

any suggestions what i need to change?

EDIT: i did another reboot and it fixed itself :upside_down_face:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.