Incoming calls are failing when Anonymous Inbound SIP calls set to no

HI all,

I am into a strange issue. I have freepbx 14 distro running and firewall enabled.

I have allowed various trusted ips in the firewall even carrier media ip’s.

I have incoming with Flow Route and what happens when I disallow anonymous calls the Pbx rejects the calls and considering their whitelisted ip’s in the firewall as unknown ip. but when I allow anonymous calls incoming works fine.

This is totally strange.

please check the rejected call logs:

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [[email protected]:1] NoOp(“SIP/fl.gg-000002b1”, “Received incoming SIP connection from unknown peer to 18015987341”) in new stack
– Executing [[email protected]:2] Set(“SIP/fl.gg-000002b1”, “DID=18015987341”) in new stack
– Executing [[email protected]:3] Goto(“SIP/fl.gg-000002b1”, “s,1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [[email protected]:1] GotoIf(“SIP/fl.gg-000002b1”, “1?setlanguage:checkanon”) in new stack
– Goto (from-sip-external,s,2)
– Executing [[email protected]:2] Set(“SIP/fl.gg-000002b1”, “CHANNEL(language)=en”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/fl.gg-000002b1”, “1?noanonymous”) in new stack
– Goto (from-sip-external,s,5)
– Executing [[email protected]:5] Set(“SIP/fl.gg-000002b1”, “TIMEOUT(absolute)=15”) in new stack
– Channel will hangup at 2018-08-28 11:45:16.501 MDT.
– Executing [[email protected]:6] Log(“SIP/fl.gg-000002b1”, "WARNING,“Rejecting unknown SIP connection from 34.210.91.114"”) in new stack
[2018-08-28 11:45:01] WARNING[26160][C-0000069b]: Ext. s:6 @ from-sip-external: “Rejecting unknown SIP connection from 34.210.91.114”
– Executing [[email protected]:7] Answer(“SIP/fl.gg-000002b1”, “”) in new stack
– Executing [[email protected]:8] Wait(“SIP/fl.gg-000002b1”, “2”) in new stack
– Executing [[email protected]:9] Playback(“SIP/fl.gg-000002b1”, “ss-noservice”) in new stack
– <SIP/fl.gg-000002b1> Playing ‘ss-noservice.ulaw’ (language ‘en’)
– Executing [[email protected]:10] PlayTones(“SIP/fl.gg-000002b1”, “congestion”) in new stack
– Executing [[email protected]:11] Congestion(“SIP/fl.gg-000002b1”, “5”) in new stack
[2018-08-28 11:45:11] WARNING[2488]: chan_sip.c:4068 retrans_pkt: Retransmission timeout reached on transmission 956deb93167e5f92c60aad8eb671cf74 for seqno 1 (Critical Response) – See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 31999ms with no response
== Spawn extension (from-sip-external, s, 11) exited non-zero on ‘SIP/fl.gg-000002b1’
– Executing [[email protected]:1] Hangup(“SIP/fl.gg-000002b1”, “”) in new stack
== Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/fl.gg-000002b1’

I had a similar problem a while back. I was never able to solve it and I’ve just been too busy to go back and figure it out. It happened when I tried to use Flowroute’s PoP servers. I contacted Flowroute and they didn’t know what the problem was. I didn’t have time to go back and forth on the problem with them, so I just switched back to not using a preferred PoP.

so what do you suggest me to do?

https://support.flowroute.com/SIP_Trunking_and_Voice/Getting_Started/Interconnection_with_the_New_PoPs

Both allow these ips in your firewall and construct trunks for them

https://support.flowroute.com/SIP_Trunking_and_Voice/PBX__Configuration_Guides/Asterisk/Configure_Asterisk_13

so we have to create new trunks for every single of their IP.

Is there any way that we can allow multiple ips in one single trunk

Probably if you use pjsip and add them to your “Match (permit)” list. Never tried it though, you only need chan_sip trunks for your main and backup servers.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.