Incoming call drops while ringing after 20 seconds - only on one extension/trunk

Last weekend I ran into a strange issue on one of my trunks. freepbx, distro 12.7.8-2008-1.sng7, asterisk 16.13.0 running go on apu2c4 hardware

I have a few trunks set up on freepbx, mainly because some single phone numbers are used “nomadically” and my provider easybell sets these up as separate account, although the numbers are part of a sip trunk. So, this is not quite a multi-tenant installation :slightly_smiling_face:
Almost on all numbers an incoming call rings > 20 seconds, before the defined action takes over (IVR, voicemail)
Only one trunk the extension stops now ringing after 20 seconds, the line just drops. Before, ring time on the extension belonging to that trunk was configured for 26 seconds. Now, with ring duration <=19 seconds everything is fine, all >= 20 secongs not. Only this trunk/extension is set up with some time conditions to determine vacation/holiday/special service hours etc.

Everything worked fine until last Friday. Then I made a test, switching voicemail off and back on on that trunk. Additionally, I ran into an issue when rebooting, kernel panic - this easily could be solved by reinstalling the most recent kernel. Also I made the latest module upgrades.

I also tried to go back to a backup from mid of last week. Back then everything still was fine, without success.

This is a comparison from the logs, with the section where the logs start differing. Left side ring time set up 19s, right side to > 19.

Any idea why this suddenly behaves differently only on one of several extensions?

Thanks for your help,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.